[ltp] Hibernate/suspend for a T420

David Woodfall dave at dawoodfall.net
Fri Nov 10 11:56:38 CET 2017

Linux raven 4.4.88 #2 SMP Thu Sep 14 14:21:06 CDT 2017 x86_64 Intel(R)
Core(TM) i5-2520M CPU @ 2.50GHz GenuineIntel GNU/Linux

I have suspend and hibernation support.

I few days ago I decided to see if my old hibernate/suspend scripts

They basically do a:

echo -n shutdown > /sys/power/disk
echo -n disk > /sys/power/state


echo -n shutdown > /sys/power/disk # although I used to not use this.
echo -n mem > /sys/power/state

They didn't work as expected so looking around I found that the thing
to try would be to stop the extra cores, and just leave one running
for sleeping/waking. So I added:

for i in /sys/devices/system/cpu/cpu*/online ; do
    echo 0 >$i

before, and:

for i in /sys/devices/system/cpu/cpu*/online ; do
    echo 1 >$i


This worked well. I could suspend, and then if I open the laptop lid
an inch or two, it would wakeup. I didn't really try out hibernate

Anyway, now I cannot suspend or hibernate at all. The laptop doesn't
fully turn off. It seems to shut down, but the power button is still
lit up and the fan seems to still be running. Nor does it beep when I
enter suspend, like it did. I haven't cheanged any system settings.

So, I tried pm-suspend and pm-hibernate to see if they would work, and
the same thing happens.

Any ideas?

More information about the Linux-Thinkpad mailing list