[ltp] My new P73 will be here Thursday

John Jason Jordan johnxj at gmx.com
Thu Dec 19 01:11:10 CET 2019

On Sat, 16 Nov 2019 12:37:54 -0800
John Jason Jordan <johnxj at gmx.com> dijo:

>I note that Canonical has certified the P73 for Ubuntu:
>But don't ask me what 'certified' means.
>Has anyone installed Linux on one? Any problems?

Well, here I am again, answering my own question! :)

I did buy a P73, and the Thunderbolt3 dock along with it. The dock
arrived in about a week and a half, but it took forever for the
computer to arrive. I placed the order on November 14 and I finally got
the computer on December 9. I let it sit in the box unopened until my
local Linux user group had a big meeting on December 15, where there
were people smarter than me to help.

The new P73 has the default i7-9750, 32GB of RAM, a 1TB NVMe drive, and
the UHD display (3840x2160).

I wanted to copy my existing Xubuntu 18.04.3 to the new Thinkpad, so my
first step was to remove the NVMe drive and put it into a USB carrier.
Using my old computer I deleted the various Windows partitions with
GPartd and then created a new root partition of 100G and another
partition for /home with the remainder of the drive.

Then I copied everything from / on the old computer to / on the new
drive, except proc, sys, etc., followed by copying everything from /home
on the old computer to /home on the new drive. Finally, I put the NVMe
back into the Thinkpad and started it up. The keyboard lights came on,
but nothing else happened.

After scratching my head and searching the net I realized that I had
used GPartd's default partition mode, and the partitions had to be
msdos instead. Back to the drawing board. Two hours of work down the
drain. I put the NVMe back into the carrier and plugged it into my old
computer. Two hours later I put the drive back into the Thinkpad and
turned it on. This time it valiantly tried to boot, but it complained
that it couldn't find / or /home.

More head scratching later I realized that the problem had to be how /
and /home had been defined in my old /etc/fstab, so I used a Knoppix
disk to edit it. I started by defining them as /dev/sda1 and /dev/sda2,
but it still wouldn't boot. Then I tried LABEL=Root and LABEL=Home,
because whenever I create a partition I also give it a label. But that
didn't work either. Finally, becoming more and more frustrated, I used
UUIDs to define them. This finally worked and I heaved a sigh of relief
when I saw the familiar Xfce login window appear.

Note: I have since discovered that NVMe drives are define differently,
like /dev/nvme0p1.

I had been booting always in Advanced mode at the Grub prompt so that I
could see what was going on. Even though it finally booted it took a
very long time and there were lots of error messages flashing by. Of
all the messages I was particularly concerned with those involving
NVIDIA, because the old computer has a 1920x1080 display, so I was
expecting issues with the display. But when it finally came up it was
at 3840x2160, so evidently Xubuntu figured out the display issues.

I am happy to say that porting my old installation to the new Thinkpad
is working well. So far all my hundreds and hundreds of applications
and configurations are working. The only big problem is changing the
settings for the size of everything. When I first launched Firefox it
came up in a window about 15cm by 30cm, and all the text was so small
I'd need a magnifying glass to read it. Ditto for everything else. It
has taken the better part of a day, and I now have all but a few little
things fixed.

Oh, I forgot one big thing that isn't working. Network manager doesn't
even see the wifi. The ifconfig command doesn't list it. The problem is
that it is a brand new Intel device, and the drivers aren't yet in my
4.15-73 kernel. I'm not planning to go anywhere with this computer for
a while so I'm content to use the ethernet cable for the time being.
But if you need wifi right away you might want to wait a bit before
buying a P73.

That's about it. I just thought I'd post something to the list to give
a heads up that the P73s work under Linux.

More information about the Linux-Thinkpad mailing list