[ltp] X1 (4th Generation) Ubuntu 16.06 trackpoint slow

Marius Gedminas marius at gedmin.as
Tue Jan 21 09:33:36 CET 2020

On Mon, Jan 20, 2020 at 10:16:31PM +0100, Uwe Brauer wrote:
> I have used so far, X40, X60 and X200s, the last two with Ubuntu 14.04,
> and although the setting was 
> sensitive   128
> speed       97
> And found it very fast and responsive,
> However in my X1 4th Generation I have (max values recognized)
> sensitive   255
> speed       255
> And it is considerable slower than the other models. 
> Setting it to lower values make it unbearable slow.
> Any idea what is going on? Could it be the BIOS?

More likely the input driver.

If you'd used a modern distro (and not one from 2016), I'd recommend
checking out https://wayland.freedesktop.org/libinput/doc/latest/trackpoint-configuration.html.

I don't remember how things worked in 2016.  I see Ubuntu 16.04 had
libinput 1.2.3.  I see that xserver-xorg-input-libinput was in universe,
so probably it wasn't the default driver for Xorg sessions.  Somehow I
don't think you're using a Wayland session.

Was trackpoint handled by the synaptics driver, or by the evdev driver?
*googles furiously*  Ah, evdev.  I don't remember anything about it, and
judging by http://www.thinkwiki.org/wiki/How_to_configure_the_TrackPoint
you've already gone as far as that road can take you.

Have you tried booting a newer distro, say Ubuntu 18.04 or 19.10 from a
USB drive, just to see if the trackpoint speed is fixed upstream?

Marius Gedminas
I am Lalo of deB-org. You will be freed. Resistance is futile.
                -- from the sig of Lalo Martins
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
URL: <http://mailman.linux-thinkpad.org/pipermail/linux-thinkpad/attachments/20200121/b34c244d/attachment.sig>

More information about the Linux-Thinkpad mailing list