[ltp] Trackpoint dead on the mainboard?

Stefan Monnier monnier at iro.umontreal.ca
Wed Jul 22 17:04:14 CEST 2020

I just replaced for the second time the right display hinge of my 14"
tallscreen T61 (seems to be a week spot in this machine), which involved
disconnecting the keyboard.

After putting things back into place and closing the machine, I now see
that while the keyboard itself works fine, the trackpoint (and its
3 mouse buttons) doesn't work any more.

I tried to reopen it re-disconnect and re-connect the keyboard, but that
didn't help.  Then I tried to swap the keyboard with that of my T60, and
lo and behold, both the T61's keyboard and the T60's keyboard work fine
(including trackpoint) in the T60 and the trackpoints of both keyboards
fail to work in the T61, showing clearly that the problem is not in the
keyboard part but in the machine/mainboard :-(

This is a major blow because I *much* prefer the trackpoint over the
touchpad (a large part of the reason why I love Thinkpads) and I love
this T61: it's my everyday work laptop; still the best laptop I can find
with the tallest screen that fits comfortably in my backpack.

Any idea what might be going on and what I might do to fix it?


More information about the Linux-Thinkpad mailing list