[ltp] Patched x240 BIOS, Technoethical Wifi and blocked Trackpad

S├ębastien Lerique sl at eauchat.org
Tue Oct 20 14:34:24 CEST 2020


Thanks for the very quick answer! I didn't expect the list to be 
so active.

>> Now when I plug in the Technoethical Wifi card (with its 
>> miniPCIe ->
>> m2 adapter), I have a curious problem: wifi works (mostly, I 
>> have a
>> NetworkManager problem but that seems unrelated to my main 
>> question: I
>> can see wifi networks but not yet connect to them), but my 
>> trackpad
>> and trackpoint don't work any more (they normally do). If I 
>> power off,
>> unplug the wifi card, and boot again, the trackpad and 
>> trackpoint
>> work.

> Your m.2 slot might share some pins with the 
> trackpad/trackpoint.  Pins
> which are unconnected with the original WiFI module but not with 
> the new
> one.
>
> This is a very common problem with USB ports being shared 
> between an m.2
> or mini-PCIe slot and some other connector.  But I guess the 
> trackpad
> and trackpoint aren't USB devices?
>
> Still, it could be a similar problem with another bus.  Look at 
> the
> pinout of an m.2 or mini-PCIe WiFi slot, and try to cover any
> optional/unused pins with e.g. a piece of tape.  This is 
> probably
> easiest to do on mini-PCIe with its larger and fewer pins. 
> Unless the
> problem is related to the adapter.  But that should be pretty 
> easy to
> test by simply plugging it in without the WiFi module.
>
> I assume the WiFi module only requires power and PCIe x1 
> signals.  But
> it will use other optional pins for LEDs, wakeup, rf disable 
> etc. Some
> of these other signals might also be required, but probably not 
> all of
> them.  And there is a good chance that the collision is related 
> to an
> optional signal.

That makes sense. I initially tried some taping on the adapter to 
copy the present/absent pins from the original Intel WiFi module, 
but the size of the pins does make it tricky. Haven't had the time 
to try again on the mini-PCIe, but will do soon.

Does it make sense to look for the collision pins with a 
multimeter (one end on the mini-PCIe pins, the other on the pins 
of the trackpad/trackpoint flex cable)? Or would there be more 
circuitry between the two and a simple multimeter wouldn't show me 
much when power is off?

Other unordered details:
- In /sys trackpoint and trackpad appear as being on an RMI4 bus
- The problem does disappear if I leave only the adapter without 
  the WiFi module

Thanks again, and I'll be back once I have tried some more!

Best,
S├ębastien


More information about the Linux-Thinkpad mailing list