[ltp] T450s mouse pointer freeze with Arch kernel 5.10.4 and 5.10.4

Paul Marwick paul.marwick at gmail.com
Sat Jan 9 04:30:39 CET 2021

I have Arch Linux Xfce installed on a T450s. Worked very well indeed up 
until the first of the 5.10.x kernels. After that, I started getting 
lightdm starting in a very low resolution mode (640x480?). A reboot 
would usually fix it, until I installed 5.10.4. With that kernel, 
rebooting didn't help. If I logged in, the resolution would go to normal 
when Xfce loaded, but the mouse pointer would be locked, not moveable 
using the touchpad or the trackpoint. Attempting to get to a console to 
shut down didn't work - all I could get was a blinking cursor. Only way 
out was to either SSH in from another machine or power cycle the laptop.

Following a hint I found, I removed xf86-video-intel, which was a 
marginal improvement. Still not functional, but at least I could get to 
a console to do a clean shutdown.

A couple of days ago, kernel 5.10.5 arrived. At first, I thought it had 
solved the problem, since I was able to log in and use the machine 
normally. Didn't last though - on the next day, I was back to having a 
locked mouse pointer and nothing usable except consoles.

I have tried plugging in a USB mouse, which worked, but isn't a very 
practical solution - I use the laptop in a number of areas which don't 
give me anywhere to put a mouse...

Has anyone seen this type of problem, or have any ideas as to how to 
diagnose and (hopefully) fix it? For the moment, I have to roll back to 
5.9.14 or use the lts kernel to get the machine to a usable state.


More information about the Linux-Thinkpad mailing list