[ltp] TP 770ED, RH 6.1, PCMCIA

Joseph Yoon linux-thinkpad@www.bm-soft.com
Wed, 22 Dec 1999 10:09:31 -0500

I do a card eject before a suspend but I still have to restart (activate) eth0
after I resume (pcmcia automatically reinserts the card if it is present so that
seems to be ok). Running RH 6.0 with kernel 2.2.9 and pcmcia 3.1 on a 770X with
Xircom CE2 10/100 CardBus. I haven't had time to figure out if this is a Xircom
"feature" or something wrong with my setup. Anybody have a guess?

I couldn't get the Xircom Cardbus working under RH 5.x.

Funny thing is, with NT4, I just disconnect the cable from the card before I
suspend and reattach after I resume and everything is fine. If I suspend before
I disconnect, then the machine is locked up on resume.

Jamie Zawinski wrote:
> I've got a Xircom 10/100 PCMCIA ethernet card, and since I upgraded to
> RH 6.1, it doesn't come back to life after a suspend.  If I close the
> lid and reopen it, I have to jump through this hoop to make my network
> be pingable again:
>         usernetctl eth0 down
>         /etc/rc.d/init.d/pcmcia restart
>         usernetctl eth0 up
> I tried a bunch of things, and it seems that those three things have to
> be done in that order.
> Everything worked fine under RH 5.1 with this card.  Has anyone else
> experienced this?  (I seem to be running kernel-pcmcia-cs-2.2.12-20.)
----- The Linux ThinkPad mailing list -----
The linux-thinkpad mailing list home page is at: