[ltp] Experience from updating RH 6.2 to RH 7.0 on TP 770X

Burt Silverman/Raleigh/IBM linux-thinkpad@www.bm-soft.com
Wed, 15 Nov 2000 14:06:11 -0500

Friedemann, Mike:

I found another bug in the TR driver. This one has been around for a long
time and has propagated. This has to do with the Adapter check interrupt
that I promised Friedemann to look at. There is at least one glaring error,
and one less glaring.

1. The line of code in ibmtr.c (approximately line number 1040)
                        check_reason = ntohs(readw(ti->sram_virt + ACA_OFFSET + ACA_RW + WWCR_EVEN));

should be changed to
                        check_reason = ntohs(readw(ti->mmio + ACA_OFFSET + ACA_RW + WWCR_EVEN));

2. According to the TR document, the adapter should be closed after an
Adapter check. I'm not sure why we are seeing what we are seeing after the
adapter check! I'd have to study it more. Note that things that lead to an
adapter check are adapter inoperative, illegal op code, local bus parity
error, external parity error, internal parity error, ring transmit or ring
receive parity error, tx underrun, rx overrun, unrecognized interrupts, and
a few more. I need to talk with a few experts to understand whether we
should try to reopen the adapter after the Adapter check.

ps seems like these adapter checks only are showing up when we bring the
adapter up.

Friedemann Baitinger      fb@baiti.net       http://baiti.net/fb/
>again and I tried all kinds of things in order to resolve it. Now that I
>know that I can hot pull/plug the card I tried this multiple times and I
>also tried the old 'ifconfig tr0 down' method -- to no luck! The
>" Arrg. Transmitter busy" problem remained persistent and the only way
>to recover was to reboot the machine. This is obviously not a desirable
>solution. Do you have alternative suggestions how to cure the situation
>without rebooting?

>For reference, here are the logs from my machine:

>Nov 13 08:54:43 blackbox cardmgr[490]: socket 0: IBM Token Ring Adapter
>Nov 13 08:54:43 blackbox cardmgr[490]: executing: 'modprobe ibmtr_cs'
>Nov 13 08:54:43 blackbox kernel:
>Nov 13 08:54:43 blackbox kernel: ibmtr_cs.c 1.10   1996/01/06 05:19:00
(Steve Kipisz)
>Nov 13 08:54:43 blackbox kernel:            2.2.7  1999/05/03 12:00:00
(Mike Phillips)
>Nov 13 08:54:43 blackbox kernel:            2.2.18 2000/10/15 Midnight
(Burt Silverman)
>Nov 13 08:54:44 blackbox kernel: tr0: ISA P&P 16/4 Adapter/A (short) |
16/4 ISA-16 Adapter
>Nov 13 08:54:44 blackbox kernel: tr0: using irq 9, PIOaddr a20, 64K shared
>Nov 13 08:54:44 blackbox kernel: tr0: Hardware address : 00:20:35:72:6E:B4
>Nov 13 08:54:44 blackbox kernel: tr0: Shared RAM paging disabled.
ti->page_mask 0
>Nov 13 08:54:44 blackbox kernel: tr0: Maximum Receive Internet Protocol
MTU 16Mbps: 16344,
4Mbps: 6104
>Nov 13 08:54:46 blackbox cardmgr[490]: executing: './network start tr0'
>Nov 13 08:54:46 blackbox kernel: tr0: Initial interrupt : 16 Mbps, shared
RAM base
>Nov 13 08:54:46 blackbox kernel: tr0: port 0xa20, irq 9, mmio 0xd085d000,
sram 0xd0000,
>Nov 13 08:54:46 blackbox kernel:   hwaddr=002035726EB4
>Nov 13 08:54:46 blackbox kernel: tr0: Opening adapter: Xmit bfrs: 2 X
16384, Rcv bfrs: 16
X 1032
>Nov 13 08:54:47 blackbox kernel: tr0: Adapter check interrupt
>Nov 13 08:54:47 blackbox kernel: tr0: 8 reason bytes follow: 06 5E 08 09
0B D2 4B 4A
>Nov 13 08:55:16 blackbox kernel: tr0: Arrg. Transmitter busy.
>Nov 13 08:55:26 blackbox last message repeated 2 times
>Nov 13 08:55:31 blackbox kernel: tr0: Arrg. Transmitter busy.

----- The Linux ThinkPad mailing list -----
The linux-thinkpad mailing list home page is at: