[ltp] PnP BIOS driver patched in 2.4.9-ac15

Tino Keitel linux-thinkpad@www.bm-soft.com
Wed, 10 Oct 2001 18:06:05 +0200

On Monday, 24. September 2001 23:31, Thomas Hood wrote:
> The patches to the PnP BIOS driver have been
> included in 2.4.9-ac15.  Note that the "boot"
> and "current" configurations will be switched
> in comparison with earlier kernels.  Thus,
> what once required "setpnp -b" now requires "setpnp"
> and vice versa.
> The driver still causes the "current" config to come
> up entirely disabled on a subsequent boot on my TP600,
> and it still fails to update its local info when setpnp
> is used to change settings.  Curing these ills will
> require further R&D.
> Thomas

I played around with the setpnp patch as well with the pnp_bios patch 
(applied some sings to the pnp_bios.c in pcmcia-cs) and changed the DMA 
settings of the IR and parallel ports. After that I always got a segmentation 
fault if I tried to access /proc/bus/pnp/devices. I switched to kernel 2.4.10 
(because of NFS server problems with 2.4.9) and rebuilt a fresh pcmcia-cs 
3.1.29 from scratch. No success. Rebooting also doesn't help. I booted into 
the Win98 on one of my spare disks and restored the old DMA settings. During 
the shutdown of Win98 the machine froze completely, forcing me to use the 
reset switch. I rebooted Linux and now lspnp works again. Obviously I had 
trashed the PnP-BIOS of my TP. :-/

I tried setpnp 12 dma -- -1 again with an unpatched setpnp/pnp_bios.c (from 
pcmcia 3.1.29) and trashed my PnP-BIOS again, any access to 
proc/bus/pnp/devices causes a segmentation fault. BTW, device 12 is the 
parallel port on my TP 765L. I used Win95 (from another spare disk :-) and 
ps2.exe to restore the DMA=3 setting, now without freezing at shutdown.

Can anyone on the list reproduce this behaviour?


----- The Linux ThinkPad mailing list -----
The linux-thinkpad mailing list home page is at: