[ltp] T21 and RedHat7.3: won't resume after suspend

Michael Selway linux-thinkpad@www.bm-soft.com
Mon, 10 Jun 2002 11:07:26 +0100

I bought a T21 9 months ago, I only run Linux on it.  On the
whole, it's great.  There have been 2 recurrent problems which
I've never fixed:

 - it crashes in various circumstances around once a month

 - around 50% of the time coming back from suspend, it hangs for
   around 15-20 seconds before the disc then spins up and all is
   then fine.  It logs these messages:

	kernel: ide_dmaproc: chipset supported ide_dma_lostirq func only: 13
	kernel: hda: lost interrupt

I've not tried very hard to solve these problems.

Last week I upgraded to Redhat 7.3 (kernel 2.4.18).  Now, around
50% of the time when resuming, the disc doesn't spin up at all.
The machine is running, but anything which tries to use the disc
hangs - and this is pretty much everything, of course.  I have to
reboot to sort it out.  It feels like this is the same problem as
I had before, only it doesn't solve itself after 20 seconds like
it used to.

I've tried several things, including D.Sen's advice (a while back)
for sorting out "lost interrupt" messages, disabling disc DMA,
unloading ethernet drivers before suspending, not loading sound
drivers, etc, etc.  None of these things made a difference.

It seems to be related to attaching/detatching mains power
before/during/after suspending.  But I haven't been able to find
any reproducable correlations.

Any thoughts?  This is really debilitating!

p.s. 3 cheers for redhat's bundling of the ext3 filesystem in
rh7.2: at least rebooting doesn't need to check the disc and only
takes a couple of minutes now.

----- The Linux ThinkPad mailing list -----
The linux-thinkpad mailing list home page is at: