[ltp] Linux, kernel 2.4.22-ac4/2.4.23 and IRDA

Steven Haigh linux-thinkpad@linux-thinkpad.org
Fri, 12 Dec 2003 03:06:29 +1100

Hmmm - is there any reason why you have to disable the serial port? I'm
still on a mission to try and get the modem to work (bloody winmodems!),
although I have got this going before, just not a priority at the

I thought things were more or less mapped out as so:

COM1 - ttyS0 - Serial Port
COM2 - ttyS1 - IR Port
COM3 - ttyS2 - Modem (when you have the modules loaded)

Does this sound right?

On Fri, 2003-12-12 at 02:55, Charles E Taylor IV wrote:
> On Fri, 12 Dec 2003 02:38:59 +1100
> Steven Haigh <netwiz@crc.id.au> wrote:
> [TP 600x]
> > I've tried just about everything I can think of to get the IR working.
> > I've heard mention that the -ac series of patches fixes support for the
> > Thinkpad IR, so have downgraded the kernel from 2.4.23 to 2.4.22-ac4,
> > but with no success.
> > The 'Enabled: no' part makes me a bit sus, however I'm assuming (and
> > maybe incorrectly) that this will change to 'yes' when I can get the
> > module to detect the IR port, but I haven't been able to find anything
> > to confirm this.
> > I have played with tpctl and the Thinkpad module, but am not currently
> > using this, as I couldn't see any major benefit in using this over not
> > using it - as APM, suspend etc seems to work fine - the only issues I
> > have is IR...
> You may have tried this already,  but have you used the DOS-based PS2.EXE
> utility to enable the IR (and disable the serial port)?  I don't have a
> 600X, but on a vanilla 600, this is what I had to do to get the IR port to
> work.  (tpctl ought to do this, but it might be easier to set it up with
> PS2.EXE and forget about it...)
> -- 
> --------------------------------------------------------------------
> *  Charles Taylor <tomalek@mindspring.com>
> *  Chemistry teacher, Linux enthusiast!
> --------------------------------------------------------------------
> *  Web: http://home.mindspring.com/~charletiv/
> --------------------------------------------------------------------
Steven Haigh
(Visit https://wireless.org.au to install our Root Certificate.)

You can lead a fool to wisdom but you can't make him think.
We have enough youth. What we need is a fountain of smart.
I am root. If you see me laughing, you better have a backup.Default