[ltp] Linux, kernel 2.4.22-ac4/2.4.23 and IRDA

Steven Haigh linux-thinkpad@linux-thinkpad.org
Fri, 12 Dec 2003 12:15:58 +1100 (EST)


I've also tried this with no joys :\

tried loading serial.o as a module *after* loading the irda/irport etc - I
still get a kernel panic when trying to run 'irattach irda0 -s'

I've just about run out of ideas now :P

AndrťWyrwa said:
> That's pretty much the same setup i have on the T23, except that i have
> 2.4.22 type of kernel (not ac).
>
>> in /etc/modules.conf, I've put:
>> options nsc-ircc io=0x2f8 irq=5 dma=3 dongle_id=0x09
>
> However, there was one more thing i had to do: to disable the kernel
> builtin serial driver.
>
> Don't remember how i came to figure this out, but i remember that i
> wondered about dmesg showing me that the kernel loaded two instances of
> the serial driver, namely ttyS0 and ttyS1. One of them was attached to
> the IR device, which makes some sense, but blocks the FIR driver from
> taking it.
>
> Since I couldn't figure out how to disable it when builtin to the kernel
> (except using setserial which i didn't want to install),
> i just built the serial driver as a module...which i rarely use.
>
> (If you have setserial try: setserial /dev/ttyS1 uart none)
>
> Maybe that helps you.
>
> Andre.
>
>
> --
> The linux-thinkpad mailing list home page is at:
> http://mailman.linux-thinkpad.org/mailman/listinfo/linux-thinkpad
>


-- 
Signed,
Steven Haigh

I am root. If you see me laughing, you'd better have a backup.