[ltp] Thinkpad R40 2722: various CPUFREQ troubles

Sebastian Kapfer linux-thinkpad@linux-thinkpad.org
Fri, 12 Dec 2003 21:34:43 +0100

Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable

Am Do, den 11.12.2003 schrieb flokno um 14:53:
> hello!


> i have the same notebook.
> did you upgrade your bios? maybe this helps...!

I upgraded when I bought the Thinkpad. Could be a good idea to visit IBM
again ;-)

> > * I Can't clock the machine at 1500 MHz when disconnected from external
> > power.
> i set speed to maximum in bios on all occasions, no powersave. always
> performance. (that is also fixed max afair). if you need more exact
> information i will have to reboot and look it up.

Same here.

> >  I know IBM wants to conserve battery power here. BUT I DON'T
> > CARE. A useless (slow) system is worse than one running two hours less.
> what is your current runtime on batteries?
> mine is always around 3 hours compared to 5:30 hours under windows.
> meaning the processor speed doesn't change much.

Between 3 and 4 hours I think. It's difficult to pin down, because I run
powernowd normally, and that changes frequency all the time. (That's the
600 MHz mode, when booting without external power. I don't normally boot
it in 1500 MHz mode and then disconnect -- alas, that seems to be the
only way to utilize the full power of the CPU.)

> > Does this depend on BIOS settings? I think I tried everything possible,
> > but never got past 600 MHz.
> yes. i think it depends.

On what? All my BIOS settings are "max performance" and it's still
running at 600.

> > * The system time runs slow. Order of magnitude is about 5 minutes slow
> > per hour of operation. This doesn't seem to occur when it is turned off=
> > I have to ntpdate several times a day. :-(  CPU frequency doesn't seem
> > to have any influence. Time is lost at about the same speed no matter i=
> > 1500 or 150 MHz. Google says ACPI will fix this (and it does), but with
> > ACPI the battery status doesn't work any more.
> with 2.6.0-test11 battery is working.

Cool. I'll try test11 then.

> but system shutdown is only possible when pressing the power button for
> some seconds after linux shutdown.

With APM, disabling APIC helped. With ACPI, mine doesn't turn off
either. A message like "acpi_shutdown called" appears, but it stays on

> > Summary of the system configuration:
> >=20
> > Pentium M CPU, Linux 2.6-test9 kernel with the CPUFREQ stuff, APM mode,
> > acpi=3Doff (you know, the battery).
> test9 is some weeks old... why not use test11?

That's a stupid reason, I know, but: Mr. Xu has not made a
kernel-source-2.6-test11 package yet. I like the Debian way to install
kernels :-) I will try test11 now and see if it recognizes the battery
in ACPI mode.

Best Regards,  | Hi! I'm a .signature virus. Copy me into
 Sebastian     | your ~/.signature to help me spread!

Content-Type: application/pgp-signature; name=signature.asc
Content-Description: Dies ist ein digital signierter Nachrichtenteil

Version: GnuPG v1.2.3 (GNU/Linux)