[ltp] slmdm driver: closing minicom through X menu hangs kernel

Dimitris Kogias linux-thinkpad@linux-thinkpad.org
Mon, 22 Dec 2003 22:58:02 -0800

Hello everyone,

I followed the instructions at:
and installed the smlink driver 1.7.10, including the PCI device ID 
change mentioned in that web page.

The modem seems to work OK (just tried minicom so far, working on PPP 
next) but I hit a weird problem:  When I ran minicom from X and tried to 
exit by accessing the File->Close Window menu option the systems locks 
hard: There's no response to the mouse and keyboard, the display is 
"frozen" and ctrl-alt-backspace, fn-f4, ctrl-alt-del all do nothing.  I 
have to press the on/off button to turn it off.

Exiting minicom using ctrl-A,X works (it also works when running minicom 
from the console since the File etc. menu isn't there).

System information:
X31 (2672)
2.4.23 kernel from kernel.org, cpufreq patch (speedstep-centrino loaded)
Debian woody

My theory is that some ioctl that minicom calls on the modem device when 
closed one particular way freezes the driver, but I don't know how to 
track down what's going on.  If someone else has a clue about what's 
going on I'd appreciate it.  Of course pointers to alternatives to the 
slmdm driver, if they exist, are also welcome.