[ltp] (another) tpctl

Ari Saptawijaya linux-thinkpad@linux-thinkpad.org
Mon, 29 Dec 2003 15:24:26 -0800 (PST)

sorry for the previous email with the same subject, it
was sent by mistake (before it was complete)

i installed Knoppix (which is Debian-based) on my
system (R40e) using kernel 2.4.23. 

To make some special buttons (volume, brigthness) work
i installed also tpctl downloaded from:

(i used thinkpad-base_4.8-1_i386.deb)

and from:
(for tpctl_4.8-1_i386.deb)

there was no problem with the installation, but these
special buttons (volume and brightness) still do not
work. at start up i saw that tpctl has also been

it is already included in /etc/modules.conf as

### update-modules: start processing
path[thinkpad]=/lib/modules/`uname -r`/thinkpad
#options thinkpad enable_smapi=1 enable_superio=1
enable_rtcmosram=1 enable_thinkpadpm=1
alias char-major-10-170 thinkpad
alias /dev/thinkpad thinkpad
alias /dev/thinkpad/thinkpad thinkpad
alias /dev/thinkpad/smapi smapi
alias /dev/thinkpad/superio superio
alias /dev/thinkpad/rtcmosram rtcmosram
alias /dev/thinkpad/thinkpadpm thinkpadpm

### update-modules: end processing

what could be the reason for these buttons to be not
working properly?

FYI, originally knoppix 3.3 (the one i used) came with
kernel 2.4.22. those special buttons (so far volumes
and brightness buttons) worked properly, and after
using kernel 2.4.23 (i tried this to get ACPI works,
and it is working), those buttons do not work anymore.

what should I check to get it work again?


Do you Yahoo!?
New Yahoo! Photos - easier uploading and sharing.