[ltp] palm (serial cradle) on a T21 thinkpad

Jim Harvey linux-thinkpad@linux-thinkpad.org
Tue, 30 Dec 2003 21:16:02 -0600

Christoph Lehmann wrote:
> how can I check, whether the serial port works/is recognized?
> chris
> On Tue, 2003-12-30 at 10:25, Christoph Lehmann wrote:
>>I alos tried /dev/ttyS1 - still no answer from the palm
>>On Tue, 2003-12-30 at 03:43, Jim Harvey wrote:
>>>Christoph Lehmann wrote:
>>>>I have suse 9 running (gnome desktop) on a T21 thinkpad. unfortunately I
>>>>cannot get any connection with my palm, even after setting a link from
>>>>/dev/ttyS0 to /dev/pilot
>>>>any help is very welcome
>>>It might be on /dev/ttyS1 if the internal modem is configured.

setserial will tell if the port is activated.  "man setserial" for information.
On this 770Z:

[root@wb8nbs jbh]# setserial /dev/ttyS0
/dev/ttyS0, UART: 16550A, Port: 0x03f8, IRQ: 4

[root@wb8nbs jbh]# setserial /dev/ttyS1
/dev/ttyS1, UART: 16550A, Port: 0x02f8, IRQ: 3

I am using the IBM mwave daemon, ttyS1 is the internal modem.
  After Armageddon, there will be only three things left: Kudzu vines creeping
  over the ruins, Cockroaches feasting on the blackened ashes, and somewhere
  an IBM PC saying "Abort, Retry, Ignore -- Abort, Retry, Ignore -- Abort... "
  Jim Harvey - WB8NBS/9 - Naperville, Illinois - Linux on a Thinkpad 770Z