[ltp] Cisco Wireless again

Carl Nygard linux-thinkpad@linux-thinkpad.org
06 Nov 2003 16:42:22 -0500

On Thu, 2003-11-06 at 15:36, Joel Ebel wrote:
> I'm trying out Fabrice's cisco driver, and I'm having some issues using 
> the wireless tools to control it.  If I start up the computer, load the 
> module and run bcard, then the card seems to work fine (it even gets an 
> IP from the DHCP server, which I don't quite get since I didn't run a 
> dhcp client).  But, when I try to configure the card with iwconfig, I 
> can get it to find the access point, but running dhcpcd doesn't get me 
> an IP.  It send it out but never gets a reply.  What's more, if I do 
> anything with iwconfig, and then run bcard, then it doens't work.  i 
> have to unload the module and reload it, and then run bcard to get it to 
> work.  Any thoughts here?  Maybe I'm missing something about iwconfig. 
> I've tried all sorts of different commands with it.  The only one I have 
> ot issue to associate with my AP is iwconfig eth0 essid any, but I've 
> tried several others and none have let me get an IP with dhcpcd.  Anyone 
> have any thoughts?  Fabrice in particular?  I'm still using 5.00.03 
> firmware.

Machine?  Kernel version?

T40/linux-2.6.0-test8-mm1:  Cisco is eth1, internal 10/100 is eth0.
I haven't had to mess with bcard at all, and iwconfig/dhclient seem to
work fine.  I have my drivers compiled into the kernel as well, and was
having problems till I figured out I had an extra entry in
/etc/modules.conf referencing the airo_mpi driver.

Carl Nygard <cjnygard@fast.net>