[ltp] Cisco Wireless again

Joel Ebel linux-thinkpad@linux-thinkpad.org
Fri, 07 Nov 2003 11:04:25 -0500

No firewall.  I haven't run iptables on the system at all, and 
everything outside the system is fine, since I can get an IP fine if I 
run bcard.  I would just prefer to use iwconfig.

I've discovered a bit more that may help.  When I run bcard, hotplug is 
called.  I don't have a great understanding of how the kernel handles 
hotplugging.  I read through all the hotplug scripts last night, but I 
don't know how the kernel decides when to call it.  When I run bcard, 
apparently the net.agent is called and my rc.inet1 is called to get an 
IP for the wireless card.  Once that is done, there is a process called 
[eth1] that I can't kill and I can't remove the airo_mpi module.  I'm 
guessing this is a result of hotplug, but I don't understand what this 
process is and why i can't kill it or remove the module.  I also don't 
know why bcard caused hotplug to run, while nothing I do with iwconfig 
seems to have that effect.

Any ideas?  I'd really like to not have to use cisco's tools.


Carl Nygard wrote:
> On Thu, 2003-11-06 at 16:58, Joel Ebel wrote:
>>That's pretty much what I'm doing.  I haven't found that setting the 
>>channel makes a difference if the mode is managed, but I tried doing it 
>>anyway.  It also doesn't seem to make a difference if I send the ap 
>>command.  I ran it just in case a few times, but I still don't seem to 
>>get a dhcp response.  I ran tcpdump and I see the packets going out, but 
>>nothing comes back.
> Stupid question, do you have a firewall in the way?