[ltp] Cisco Wireless again

Fabrice Bellet linux-thinkpad@linux-thinkpad.org
Sat, 8 Nov 2003 18:06:37 +0100


On Fri, Nov 07, 2003 at 11:04:25AM -0500, Joel Ebel wrote:
> No firewall.  I haven't run iptables on the system at all, and 
> everything outside the system is fine, since I can get an IP fine if I 
> run bcard.  I would just prefer to use iwconfig.
> I've discovered a bit more that may help.  When I run bcard, hotplug is 
> called.  I don't have a great understanding of how the kernel handles 
> hotplugging.  I read through all the hotplug scripts last night, but I 
> don't know how the kernel decides when to call it.  When I run bcard, 
> apparently the net.agent is called and my rc.inet1 is called to get an 
> IP for the wireless card.  Once that is done, there is a process called 
> [eth1] that I can't kill and I can't remove the airo_mpi module.  I'm 
> guessing this is a result of hotplug, but I don't understand what this 
> process is and why i can't kill it or remove the module.  I also don't 
> know why bcard caused hotplug to run, while nothing I do with iwconfig 
> seems to have that effect.
> Any ideas?  I'd really like to not have to use cisco's tools.

I don't know why the hotplug scripts are called in this case. They probably
try to automatically configure the card on their own side, while you 
also try to configure it with bcard/iwconfig manually. I don't know how 
does Slackware perform the configuration of a wireless card, but RedHat 
calls iwconfig repeatedly with the parameters (ESSID/CHANNEL/WEP_KEY) 
that you fixed in /etc/sysconfig/network-scripts/ifcfg-eth1, and calls a 
dhcp client afterwards, if needed. 

I'd suggest to try to prevent the hotplug scripts to run, at least in a
test phase, so the only commands received by the card will be yours.

. What are exactly the commands that you send to the card with iwconfig ?
. and how does each command modify the output of 'iwconfig eth1' ?
. do you have WEP encryption enabled ?

I use this minimalist wireless configuration script :
     - iwconfig eth1 essid xxxxx
         -> this should modify the ESSID field of 'iwconfig eth1' (factory
	    name is "tsunami")
     - iwconfig eth1 channel NN
         -> this should modify the Frequency field of 'iwconfig eth1'
     - iwconfig eth1 key xxxx-xxxx-xxxx-xxxx-xxxx-xxxx-xx
         -> this should modify the Encryption key field, moreover, the
	 access point MAC address should appear instead of 

     - then you can configure the eth1 interface (manually with ifconfig,
       or automatically with a dhcp client).

That's all. Nothing more, nothing less.

If ifconfig reports that packets are correctly emitted, but that no packet
is received, then you probably have a wrong WEP key, or a problem of this
kind. IIRC, bcard also configures the wep key index to be used. There're
several WEP key slots, and only one is used to encrypt packets. It is 
also possible to select which slot is the active one with iwconfig,
but this feature is quite obscur (see the key/enc[ryption] section of the

Best wishes,