[ltp] My Wireless Experiences with a T41

Greg Meyer linux-thinkpad@linux-thinkpad.org
Wed, 12 Nov 2003 20:57:15 -0500

I thought some of you would be interested in my experiences getting wireless 
networking going on my T41.  The machine originally came with a Centrino 
wireless card which I swapped out for a Cisco Aironet MPI350 knowing that the 
Intel card had absolutely no driver support in Linux (two days after I 
received my machine, Linuxant announced their driverloader product, but I'll 
get to that later).

My card came with firmware version 5.02.17, so the first thing I did was to 
downgrade it to version 5.00.03, which is the version that came with the 
Linux driver available from Cisco.  I will shamefully admit that I used the 
Windows version of the Cisco ACU to do this because I didn't want to spend a 
lot of time with it.  After downgrading the firmware, I followed Fabrice 
Bellet's instructions for building the airo_mpi driver found here:


He reports in his Linux on a T40 document that this driver only works with the 
5b00.08, but I thought I would give it a shot anyway.  


The module built without issue and modprobed without complaining, but i could 
not get it to associate with the AP.  It would also frequently cause a kernel 
panic when I tried to activate the interface.

Not willing to give up, I tried to build the Cisco driver, which is shipped 
with the 5.00.03 firmware, so I was hoping I could at least use that.  I had 
all kinds of difficulty because even though I was trying to build mpi350, the 
installer wanted to update pcmcia-cs.  I gave up rather quickly because I 
decided to try the Linuxant driverloader solution to see if it worked.

I rebooted into Windows and installed the latest driver and firmware available 
from the Cisco website.  I then rebooted to Linux and went through the 
Linuxant installer.  It was a very simple process.  It involves installing a 
package (comes in rpm, deb or tgz) and using a web interface to install the 
windows driver.

I used the generic rpm because I am running the most recent mandrake kernel 
which Linuxant has not built a package for yet.  The rpm built it's own 
kernel module and finished in less than a minute.  I used the web interface 
to upload the same driver I had just installed in Windows, and it all went 
very quickly and in about 5 minutes I was up and running.

I now have a working wireless connection on my home network.  The only problem 
I am still having is that I am having trouble using the AP at my office, 
where they have 128-bit WEP turned on.  I suspect at this point my 
difficulties have more to do with my lack of familiarity with the 
wireless-tools package than with a problem in the driver.  I have left any 
authentication off for the time being on my home network so I can make sure 
the connection works before adding variables that have the potential to cause 
problems.  The wireless connection at work is really not a problem, because I 
really wanted the wireless solution for home anyway.

If anyone has any experience with using the wireless-tools with the Linuxant 
driverloader, I would be interested in hearing from you.

The Linuxant driverloader comes with a restrictive 30-day trial license.  A 
permanent license is $19.95.  I will probably buy it and stay with this 
solution until the airo_mpi driver matures and works with later firmware.  I 
really don't want to downgrade this firmware because this version solves the 
problem I was having in Windows of the wireless connection dropping after 5 

Also, if I knew I was going to end up here, I probably would have skipped the 
Cisco card and stuck with the Intel Centrino card and used the driverloader 
straight away saving , although now I have the equipment to test the future 
revisions of the open source driver, so perhaps I can help that solution get 

If you made it this far, thanks for reading this.  Hopefully this helps 
anybody considering a built in WiFi solution on their Thinkpad.

"Outside of a dog, a man's best friend is a book, inside
a dog it's too dark to read" -Groucho Marx