[ltp] My Wireless Experiences with a T41

Greg Meyer linux-thinkpad@linux-thinkpad.org
Thu, 13 Nov 2003 13:31:34 -0500

On Thursday 13 November 2003 08:43 am, Sean Dague wrote:
> For what it is worth, I happily run bellet's airo_mpi driver on a T40,
> firmware 5.00.03, Linux Mandrake 2.4.22-21mdk kernel.  The older versions
> of the driver (i.e. August & Sept releases) used to give up the ghost after
> some period of time, or under heavy traffic, but everything has been great
> after the October releases.
> On certain waps I needed to use the acu utility to bring up the connection,
> but at home, at 128bit WEP, I can just use the linux wireless tools
> directly.

Well Sean, your post gave mt the impetus to give it another try, and I got the 
airo_mpi driver working with 5.00.03 firmware.  I have also solved the WEP 
authentication issue I was having so I owe you a big thank you.

I deleted all the modules from modules.conf, booted into Windows and 
downgraded the firmware to 5.00.03, booted back into Linux and rebuilt the 
airo_mpi module.  modprobed it and then brought up the interface and it 
worked.  I'm not sure what I was doing wrong the first time, but I am now a 
happy camper.

"Outside of a dog, a man's best friend is a book, inside
a dog it's too dark to read" -Groucho Marx