[ltp] My Wireless Experiences with a T41

Theodore Ts'o linux-thinkpad@linux-thinkpad.org
Fri, 14 Nov 2003 17:07:26 -0500

On Thu, Nov 13, 2003 at 01:31:34PM -0500, Greg Meyer wrote:
> I deleted all the modules from modules.conf, booted into Windows and 
> downgraded the firmware to 5.00.03, booted back into Linux and rebuilt the 
> airo_mpi module.  modprobed it and then brought up the interface and it 
> worked.  I'm not sure what I was doing wrong the first time, but I am now a 
> happy camper.

For whatever it's worth, I've tried downgrading the firmware to
5.00.03, built airo_mpi-20031108 under Linux 2.4.23-pre9, and while I
can correctly associate with access points, and scan for available
access points using the iwlist scan command, I'm not able to receive
any packets.  The "invalid misc" statistic just goes up, but nothing
else works...  The card works fine under Windows, though, so I'm not
sure what's going on, given that many other people have reported
success with this configuration.

						- Ted