[ltp] SuSE 9 on T40

Aaron Mulder linux-thinkpad@linux-thinkpad.org
Thu, 13 Nov 2003 14:22:16 -0500 (EST)

	I didn't upgrade, I installed from scratch.  I'm not sure what
detail I can provide that would be helpful to you, but if you name it,
I'll provide it.  I have the IBM a/b wireless card, a 60GB hard drive, and
otherwise stock hardware.  I disabled ACPI (which caused suspend problems)
by adding "acpi=off" to the kernel boot command line in the GRUB config
file (as well as "chkconfig acpid off").  I enabled APM with "chkconfig
apmd on".  I haven't had any troubles suspending or resuming (in fact,
it's damn fast to resume, like 2 seconds).  I always do it from X-Windows
though (I've heard of problems in the past with suspending from the
console, though that wasn't a SuSE issue AFAIK).  I used to have problems
suspending and resuming when I had a compact flash card in a PCMCIA slot
-- I haven't tried it with SuSE yet.

	The slow shutdown definitely sounds like ACPI to me -- when I 
tried to suspend with ACPI it seemed to send the machine to "286 mode" 
(about 8 MHz), and it took *forever* to shut down.  Look in 
/boot/grub/menu.lst and make sure you have "acpi=off" in all your kernel 
configurations.  Just turning off the acpid service is not enough.


On Mon, 10 Nov 2003, Valient Gough wrote:
> Hmm.   I upgraded from SuSE 8.2 to 9 last week on my T40p and am having
> problems with it.
> Under 8.2, I had no problems with suspend/resume with apm.  I could go
> weeks without rebooting my laptop by just suspending it at night.   I
> don't have any suspend partition on disk, so this was just suspend to
> ram.
> Under SuSE 9, the system hangs on resume almost every time (using APM
> still - ACPI causes severe problems after ~20-30 minutes).  I've tried
> switching out of X, removing most modules, use apm instead of the lid
> switch or Fn-F4, but everything still leads to the system crashing on
> resume.  Even worse is that twice for some reason the screen actually
> came back on after resume and the keyboard worked, but then the IDE
> interface was hosed in some way and I had streams of sector not found
> errors being spewed to my log files. It was *very* slow to shut down --
> about 30 minutes.  This testing has lead to a lot of hard reboots, and
> fortunatly the reiserfs partition hasn't lost anything yet (and I've
> been making backups just in case).
> So I'm surprised that suspend works well for you.   Do you have any more
> details about how you've setup your system?
> regards,
> Valient
> On Mon, 2003-11-10 at 12:32, Aaron Mulder wrote:
> > 	Just thought I'd drop a note to say I'm running SuSE 9 on my T40p
> > and it works quite well.  It autodetected everything, including the
> > madwifi driver for the IBM a/b card (which it configured as wlan0 instead
> > of ath0).  It defaulted to ACPI, which I had to disable in favor of APM
> > (as suspend doesn't work).  But it includes /proq/cpufreq and a daemon
> > called cpufreqd which is very customizable and controls the CPU speed
> > effectively.  It also includes /proc/sys/vm/laptop_mode.  It detected the
> > ATI card successfully, though I had to pick a generic LCD display as the
> > monitor.  DMA worked for the disk drive, and it detected the CD-RW/DVD
> > combo drive with the appropriate capabilities.  I haven't fussed with the 
> > touchpad drivers as I prefer to use the eraser mouse.
> > 
> > 	The only problems I've had have been with 3rd-party software that
> > only works with Red Hat kernels (such as the Nortel Contivity VPN client).
> > 
> > Aaron