[ltp] My Wireless Experiences with a T41

Greg Meyer linux-thinkpad@linux-thinkpad.org
Fri, 14 Nov 2003 21:10:06 -0500

On Friday 14 November 2003 05:07 pm, Theodore Ts'o wrote:
> On Thu, Nov 13, 2003 at 01:31:34PM -0500, Greg Meyer wrote:
> > I deleted all the modules from modules.conf, booted into Windows and
> > downgraded the firmware to 5.00.03, booted back into Linux and rebuilt
> > the airo_mpi module.  modprobed it and then brought up the interface and
> > it worked.  I'm not sure what I was doing wrong the first time, but I am
> > now a happy camper.
> For whatever it's worth, I've tried downgrading the firmware to
> 5.00.03, built airo_mpi-20031108 under Linux 2.4.23-pre9, and while I
> can correctly associate with access points, and scan for available
> access points using the iwlist scan command, I'm not able to receive
> any packets.  The "invalid misc" statistic just goes up, but nothing
> else works...  The card works fine under Windows, though, so I'm not
> sure what's going on, given that many other people have reported
> success with this configuration.
> 						- Ted
This very similarly describes my experiences the first time around.  I think 
my problem was that I was using Shorewall as my firewall and I neglected to 
add eth1 as an interface, so all traffic was being blocked.  I enabled eth1 
in my shorewall configuration during my attempts to get the Cisco driver to 
build, so obviously the driverloader worked okay.  When I tried the airo_mpi 
driver again, it worked, so it could have been shorewall that caused my 
initial problems, but I can't be sure at this point, because though I 
normally take good notes, I didn't in this instance.

"Outside of a dog, a man's best friend is a book, inside
a dog it's too dark to read" -Groucho Marx