[ltp] Problems accessing USB 2.0 disk from T40

Stefan Farestam linux-thinkpad@linux-thinkpad.org
Wed, 19 Nov 2003 11:43:02 -0800

Yes, I have had the same issues and haven't resolved them yet. My
experience was with a T40 + Fedora Core 1 standard kernel. I was
afraid that it potentially was a hardware problem with the case
that I used, but your response seems to indicate that it may rather
be a driver issue.

I tried removing the ehci-hcd module, thus reducing the interface
to USB1. Usbview showed that the interface was no more USB2
compliant, but I still have problems.

So, at this point I suspect that the problems may be usb-storage
related rather than USB1 vs USB2 related.


On Wed, 2003-11-19 at 03:17, Jordan Benjamin wrote:
> I just got a 120GB 7200 RPM hard drive in a USB 2.0 enclosure for 
> backup using partimage. When I connected it to my T40 and tried saving 
> some partition images to it, I found that the transfers were quite 
> slow, and would pause for long periods of time. hdparm -t /dev/sda 
> showed something like 750K/s, under the SystemRescueCD 0.28 and Fedora 
> Core 1. I then read somewhere that there were problems with USB access 
> in earlier kernel version, but that they were fixed in 2.6.0, so I 
> tried a Gentoo 2.6.0 live CD. Now hdparm -t reports ~25MB/s, but 
> partimage still freezes (it'll transfer 100MB in a few seconds and then 
> sit for 30-60sec).
> Has anyone had any problems like this?
> Jordan