[ltp] Problems accessing USB 2.0 disk from T40

Victor Pechorin linux-thinkpad@linux-thinkpad.org
Thu, 20 Nov 2003 11:05:30 +0100

I have the same problem on T40+RH9 with WD 200 Gb combo USB/FireWire
drive, kernel 2.4.22-ac4, after transfer 50-60 Mb it freezes for 4-5
seconds... But i've found that the same problem is on another computer
with Win98SE. But it works without breaks and very fast on the same

On Wed, 2003-11-19 at 12:17, Jordan Benjamin wrote:
> I just got a 120GB 7200 RPM hard drive in a USB 2.0 enclosure for 
> backup using partimage. When I connected it to my T40 and tried saving 
> some partition images to it, I found that the transfers were quite 
> slow, and would pause for long periods of time. hdparm -t /dev/sda 
> showed something like 750K/s, under the SystemRescueCD 0.28 and Fedora 
> Core 1. I then read somewhere that there were problems with USB access 
> in earlier kernel version, but that they were fixed in 2.6.0, so I 
> tried a Gentoo 2.6.0 live CD. Now hdparm -t reports ~25MB/s, but 
> partimage still freezes (it'll transfer 100MB in a few seconds and then 
> sit for 30-60sec).
> Has anyone had any problems like this?
> Jordan
Victor Pechorin