[ltp] Suspend/resume on T40

Satish Balay linux-thinkpad@linux-thinkpad.org
Thu, 9 Oct 2003 14:47:16 -0500 (CDT)

On Thu, 9 Oct 2003, Carl Nygard wrote:

> I've followed a few threads about suspend/resume, and I thought what I
> did should work, according to others' experience.  I have a stock RH9
> install, with my own 2.4.22-ac4 kernel (CONFIG_APM_DISPLAY_BLANK=n,
> CONFIG_VESA_FB=y).  cpudyn is speedstep-ing the processor nicely.
> I also updated the XFree86 rpms from the fedora severn beta
> At this point, the screen turns off if I shut the lid, turns back on
> properly, X resumes fine (this also worked before upgrading XF86).
> I expected the severn XF86 beta rpms to allow the Fn-F3/4 keys to work
> properly, but nothing at all happens.  I can turn on the light and dim
> the lcd with the Fn-xx keys, so the Fn key seems to be working.
> I'm about to try updating gdm as well from the severn beta, but I don't
> know if that will have an effect.
> Anyone have other clues?

Perhaps you can also try the severn/rawhide kernel?

I've started from severn (beta 2) and upped to rawhide using 'yum' and
Fn-F3/4 worked with both. Note: this is with APM.

I've tried booting to ACPI with the latest rawhide kernel - but
Fn-F3/4 don't work.

I haven't tried cpudyn - does this require ACPI?