[ltp] Re: Re: [R40] middle `mouse' button above touchpad

Tony Whitmore linux-thinkpad@linux-thinkpad.org
Sun, 25 Jan 2004 21:32:09 +0000

Patrick Drechsler wrote:
> Mika Fischer wrote on 25 Jan 2004 01:24:09 MET:
>>Patrick Drechsler wrote:
>>>I tried your code `as is' and with a few modifications
>>>(/dev/...) but didn't even get an X-Server to run.
>>>In case it makes a difference: I'm using SuSE 8.2 prof
>>>If you need more information on my system to solve this -- just
>>Well, the error message would be really helpful :)
>>You have to make sure that your new InputDevice named TouchPad is also
>>included in the ServerLeyout Section at the end of the file.
> Since this isn't crucial for my system I'll have to postpone
> this adventure to the future. I'm pretty busy at the moment but
> I'll be back with a correct beacktrace.
>>You can find my XF86Config in its entirety here:
> Thanks, I saved the file and as soon as I get the chance I'll
> test it. Although I have my doubts about this working with
> kernel <2.6...but I'll give it a try.

Hi, I've only just signed up to the list. I'm running Debian Unstable on 
my R40 and have been for the last few weeks. I've been generally 
successful but still have a few niggles that I'm trying to iron out - 
and this is one of them.

I've just tried the "TouchPad" section from the XF86Config-4 file that 
Patrick posted, but X refuses to start because the synaptics driver is 
not located. I'm running XFree86 4.3.0 binaries from www.xfree86.org. Is 
there anything special I need to do to initialise this driver?