[ltp] t43p hardware problems

Steven J. Owens linux-thinkpad@linux-thinkpad.org
Wed, 18 Jun 2008 17:39:10 -0400

Hi folks,

     I have a t43p with 15" screen, that I bought nearly three years
ago (summer of 2005).  I've been very happy with ubuntu and my T43p
for most of the time I've had it.  Now it's almost at the end of the
hardware warranty, and I'm experiencing several hardware issues.

     My fan died in 2007, which was annoying enough, but a frequent
problem with this model.  IBM sent me a new fan, and also replaced my
battery at that time, due to a battery recall.

     Mid-may 2008, my drive failed. IBM sent me a replacement, I did a
fresh install of the next version of Ubuntu, 8.0.4 Hardy Heron.

     Two weeks later, I started having problems with my wireless,
which I then attributed to a kernel upgrade from 2.24.6-16.

     During the process of monkeying with the kernel trying to revert
it, and doing lots of reboots, I started having problems with the
laptop failing to boot up.

     I learned that the fail-to-boot was because of problems with the
LCD screen.  When I plugged in an external monitor, it booted.

     At the time, I assumed that the wireless was due to the kernel
upgrade and that the boot problem was due to my monkeying with the
kernel trying to fix the wireless.  However, I have since reinstalled
my root partition using the original install CD and I'm still having
both problems.

     I guess what I'm wondering is:

     Are other t43p owners seeing these kinds of problems?

     Are they hardware failures, or is there possibly some subtle
change wrought by the linux installation that would stick through a

     If I end up shipping this back to IBM, is there anything else I
should ask them to check on while they have it?

     Will they give me grief about sending them a thinkpad with linux
installed on it?

     I have the winxp install disks they sent with the hard drive
replacement; should I try installing winxp before I send it back to

More detail:

     The power icon LED and the battery charging icon LED both light,
the fan powers up, but the LCD screen stays dark, no IBM hardware
splash screen, no power to the screen at all, as far as I can tell,
and no other activity (drive noise, drive LED, etc) occurr.  Leaving
it alone (powered up) for 20-30 minutes didn't help.  Holding down the
power button to force a shutdown and then starting again sometimes
helped, but sometimes got the same failure.

     A couple of times it just failed to boot no matter what I did.
Leaving it turned off for a few hours (on the theory that the problem
might be heat-related) seemed to to help.

     Eventually I reinstalled Ubuntu Hardy from the original install
CD I'd used (which kernel 2.24.6-16, which had worked fine). But even
after that, the wireless just never worked, and then shortly after
that, the laptop just never booted.

     I tried plugging in a separate monitor to the video out and then
it booted.  I discovered quite by accident (when I left the install CD
in the drive) that if I booted in a video mode that the monitor can
support (the monitor I have can't do the full 1200x1600), and then
unplug the monitor, then the laptop LCD comes on.

     At this point, I decided it was a hardware issue after all, and
called IBM tech support.  Turns out the t43p has a surge protector
that is built into the LCD screen.  The support guy talked me through
disconnecting the battery, unplugging the power and holding the power
button down for 30 seconds to reset it.

     Bingo, it booted up.  But still no wireless.  And then the failure
to boot came back, and I reset it, and it came back, etc.

     Eventually I gave up and called back IBM tech support.  They told
me I'd have to ship it back to them for repairs and we set up an RMA.

     Just now I went to reboot and try logging in under a new user account
(since I kept my old /home when I reinstalled), to see if there was
possibly some subtle account-specific setting that was messing with the
wireless. I shut down, let it sit for a minute, then powered up
and it beeped twice and displayed:

Resource Conflict - PCI on Motherboard
   Bus:04, Device:00, Function:04

Press <F1> to Setup

Steven J. Owens
puff@darksleep.com / (412) 401-8060 cell 
| "I'm going to make broad, sweeping generalizations and strong,
|  declarative statements, because otherwise I'll be here all night and
|  this document will be four times longer and much less fun to read.
|  Take it all with a grain of salt." 
|  - http://darksleep.com/notablog