[ltp] Problem with Interl Pro/100 VE

Timothy Murphy linux-thinkpad@linux-thinkpad.org
Sun, 21 Jun 2009 00:13:43 +0100

I recently acquired a Thinkpad T23 (1647-BG9)
which has an Intel Pro/100 VE (82801CAM) ethernet controller
(according to Linux lspci).
But I don't seem able to connect to my home LAN through ethernet
although I can connect with WiFi (through a PCMCIA Orinoco Gold card)
without problem.

I'm running Fedora-10; basically I want to upgrade to Fedora-11
through preupgrade, but this required an ethernet connection
(I don't know why).

When I boot the laptop with ethernet connection (but not WiFi)
the NetworkManager icon goes round for a minute,
and when I hover over it I get the message:
Requesting a wired network address for 'System eth0'

But when I look at my dhcpd server,
I see no evidence that the machine has tried to connect.
According to ifconfig some 85 packets have been received,
and 25 sent out. But where these came from (or went to) I have no idea

When I left click on the NM icon, I am offered "Auto eth0" and "System eth0".
What exactly is the difference between these?

I've tried stopping the NM service, and starting the network service,
but that does no better.

I wonder if anyone has a T23 with the Intel Pro/100 controller,
and has had better luck than me?

Timothy Murphy  
e-mail: gayleard /at/ eircom.net
tel: +353-86-2336090, +353-1-2842366
s-mail: School of Mathematics, Trinity College Dublin