[ltp] Replacement Battery not Charging

Yannick Gingras linux-thinkpad@linux-thinkpad.org
Tue, 26 Jan 2010 17:32:22 -0500

Content-Type: Text/Plain;
Content-Transfer-Encoding: quoted-printable

Hello Thinkpad users,=20
  I have an X61 and I recently ordered a replacement battery from ebay.
It's a 8-cell SANYO with a rated capacity of 74950 mWh.  The problem
is that it won't charge.  The first time I tried it, it would sate
"fully-charged" but the meter would show it at 60%.  I ran on it for
some time then it started charging.  I drained it to 0% to reset the
fuel gauge but then it would stay there and would not charge.  I tried

  echo 1 > /sys/devices/platform/smapi/BAT0/force_discharge

and there it started to charge.  I was stuck with that mess for a few
cycles.  No matter what the remaining charge was, it would not charge
and would show up at "fully charged XX%" in KDE.  If I force the
discharge for a few minutes, it would eventually start charging but
after maybe 10 cycles, it won't do it again.  It just sits there and
won't charge.

Is there a way to force the charger to kick in?

Yannick Gingras
http://confoo.ca -- track coordinator
http://montrealpython.org -- lead organizer

Content-Type: application/pgp-signature; name=signature.asc 
Content-Description: This is a digitally signed message part.

Version: GnuPG v1.4.9 (GNU/Linux)