[ltp] Replacement Battery not Charging

Ivan T. Ivanov linux-thinkpad@linux-thinkpad.org
Wed, 27 Jan 2010 10:00:37 +0200


On Tue, 2010-01-26 at 17:32 -0500, Yannick Gingras wrote:
> Hello Thinkpad users, 
>   I have an X61 and I recently ordered a replacement battery from ebay.
> It's a 8-cell SANYO with a rated capacity of 74950 mWh.  The problem
> is that it won't charge.  The first time I tried it, it would sate
> "fully-charged" but the meter would show it at 60%.  I ran on it for
> some time then it started charging.  I drained it to 0% to reset the
> fuel gauge but then it would stay there and would not charge.  I tried
> to 
>   echo 1 > /sys/devices/platform/smapi/BAT0/force_discharge
> and there it started to charge.  I was stuck with that mess for a few
> cycles.  No matter what the remaining charge was, it would not charge
> and would show up at "fully charged XX%" in KDE.  If I force the
> discharge for a few minutes, it would eventually start charging but
> after maybe 10 cycles, it won't do it again.  It just sits there and
> won't charge.
> Is there a way to force the charger to kick in?

What says

$ cat /sys/devices/platform/smapi/BAT0/stop_charge_threshold  

...or something