[ltp] Trackpoint device on T400s with Debian Testing

Petar Milin linux-thinkpad@linux-thinkpad.org
Tue, 27 Jul 2010 18:56:30 +0200

Hello ALL!
Two days ago I installed Debian Testing on my T400s, and it has been 
extremely flawless experience. Just a few tweaks, here and there. The 
only pain was caused by the trackpoint device -- mid-button scroll did 
not worked at all. Now, I read and tried few things:
- from general -> 
- to more distribution-specific -> 
Nevertheless, nothing helped:
- GPointing Device Settings, installed via Synaptic, run only first 
time. Then, after nothing happened with the trackpoint, each succeeding 
opening of this front-end ended with its crash (it could not be opened 
for the second, third etc. time).
- Since hal is to be depreciated, this did not work either. I even could 
not find /etc/hal/ folder and its subfolders, where ibm_trackpoint.fdi 
or mouse-wheel.fdi should be placed (exactly in /etc/hal/fdi/policy/). 
Those two files should do the same, yet they do nothing at all.
- Neither making /usr/lib/X11/xorg.conf.d/20-thinkpad.conf (xorg.conf.d 
approach) nor /etc/udev/rules.d/99_trackpoint.rules (udev approach) 
files helped.
Finally, I have found following post:
There, guy suggested to make xorg.conf file in /etc/X11/, as in the old 
days. I tried that too and, voila: it worked!

Now I wander if this is right!? According to ThinkWiki, preferred way 
should be via graphical front-end (GPointing Device Settings). xorg.conf 
was in place long time ago. Later, I recall that I fixed trackpoint in 
Ubuntu 9.04 using hal (making /etc/hal/fdi/policy/ibm_trackpoint.fdi 
file). This is now, again, depreciated and xorg.conf is back?!

In brief, I need my Debian for work, and I would like to have it as 
rock-stable as it should be, and not to tweak something in inappropriate 
way. Thus:
(a) Why GPointing Device Settings does not work and why it crashes after 
initial/first loading?
(b) Is xorg.conf, now and again, right way to make trackpoint functional?