[ltp] T520 Ubuntu 11.10 x64 - can't connect external monitor

Richard Neill linux-thinkpad@linux-thinkpad.org
Sat, 04 Feb 2012 11:09:01 +0000


Dear Fen,

It looks like you've tried most of the "obvious" things. A few thoughts:

1. Which driver are you actually USING? (it will say in Xorg.0.log which 
drivers have been attempted, and which one it finally uses.) It's 
sometimes possible to think you are using nouveau when you're actually 
using nv, etc.

2. The nvidia binary blob also installs its own copy of (iirc) libGlx.
So to switch away from it, you need to completely uninstall the nvidia 
packages, not just swap the xorg.conf.  [This info may be outdated, it 
was certainly true last time I had such woes.]

3. Just in case, have you read this:
    http://www.thinkwiki.org/wiki/Switchable_Graphics

4. I suspect that you may find this problem is solved "upstream". There 
is a lot of troubleshooting you can do, but it may be worth installing 
different distros to a live USB stick, and seeing whether any of them 
will work for you. I'd suggest trying the unstable version of Ubuntu 
(Precise Pangolin), and the latest Fedora. This experiment won't take 
too long to do; Unetbootin will help.


Hope that helps - sorry I can't be any more specific.

Richard


On 04/02/12 01:12, Fen Labalme wrote:
> Hi Richard,
>
> Thank you so much for your reply - it gives me hope that I might be able
> to get tis to work.
>
>
> On Fri, Feb 3, 2012 at 6:45 PM, Richard Neill <rn214@richardneill.org
> <mailto:rn214@richardneill.org>> wrote:
>
>     On 03/02/12 19:27, Fen Labalme wrote:
>
>         I have a new T520 that mostly works fine  I currently run
>         nvidia (NVS
>         4200M) discrete graphics, have compiz 3d effects and colors look
>         good.
>
>
>     Have you tried all 4 possible drivers:
>       vesa/fbdev
>       nv  (the old one)
>       nouveau (the new free driver)
>       nvidia (the binary blob from nvidia.com <http://nvidia.com/>)?
>
>
> No.  With freshly installed 11.10 I was not able to get the monitor to
> work using Intel Integrated nor Discreet Nvidia GPU.  When I first tried
> nvidia, I imagine (just guessing, here) that it was running nouveau.  I
> read somewhere that the new closed source drivers were worth a try, so I
> installed them using the xswat PPA.  I have not tried nv nor (to my
> knowledge) vesa/fbdev.
>
> Installed nouveau drivers:
> ii  libdrm-nouveau1a                  2.4.26-1ubuntu1
> ii  xserver-xorg-video-nouveau        1:0.0.16+git20110411+8378443-1
>
> Installed nvidia drivers:
> ii  nvidia-common                     1:0.2.35
> ii  nvidia-current                    290.10-0ubuntu1~oneiric~xup1
> ii  nvidia-settings                   290.10-0ubuntu1~oneiric~xup1
>
>     What does /var/log/Xorg.0.log say?
>
>
> Using nvidia driver 290, a DisplayPort->DVI cable and the nvidia-settings:
>
> I turn on Twinview, save the xorg.conf file and apply my settings, I get
> a bar maybe 450 pixels high and across both screens containing what
> looks like my laptop windows spread wide.  After the timeout, laptop
> returns to normal and monitor goes back to dark.  I got this in Xorg.0.log:
>
> [ 22145.454] (II) NVIDIA(0): Setting mode
> [ 22145.454] (II) NVIDIA(0):
> "DFP-0:1600x900@1600x900+0+0,DFP-1:nvidia-auto-select@1920x1200+1600+0"
> [ 22145.621] (WW) NVIDIA(0): Option "TwinViewXineramaInfoOrder"
> requested "CRT", but no
> [ 22145.621] (WW) NVIDIA(0):     such display device could be found, or
> all display devices
> [ 22145.621] (WW) NVIDIA(0):     by that name are currently unavailable.
> [ 22145.622] (WW) NVIDIA(0): Option "TwinViewXineramaInfoOrder"
> requested "TV", but no such
> [ 22145.622] (WW) NVIDIA(0):     display device could be found, or all
> display devices by
> [ 22145.622] (WW) NVIDIA(0):     that name are currently unavailable.
>
>     Also, just to check - it's sometimes possible to accidentally
>     disable the outputs in the BIOS, or the Fn-F7 key.
>
>
> Good "is it plugged in?" question, but the outputs are enabled in BIOS
> and I have tried the Fn-F7 key.  Also, I have two cables: VGA-VGA and
> DisplayPort->DVI.  For my monitor (1920x1200) I think the latter would
> be better, but of course I need the VGA to work for connecting to e.g.
> projectors.
>
> I try going back to nouveau as I didn't give it much of a chance.  Looks
> like the nouveau I have is nouv-old (20110411) - mayhaps I should try
> downloading a newer one?
>
> I've scoured the web but have not found recommended setups.  4x nvidia
> drivers; 2x intel; 2x cables; many (!) possible settings in xorg.cong.
> Any suggestions as what to concentrate on?
>