[ltp] X200 wireless hard blocked

Jochen Spieker linux-thinkpad@linux-thinkpad.org
Sun, 29 Jul 2012 02:18:29 +0200

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable


Today I diseaasmbled my X200 in order to renew its thermal paste. That
part worked out ok.

The problem is that I am an idiot and broke the internal slot for the
wifi card. I managed to bend several pins enough so that I cannot insert
the card anymore.

Then I tried to use the other slot which at first appeared to work fine.
The card is detected by the system and the module iwlagn gets loaded on
boot. But:

$ sudo ifconfig wlan0 up
SIOCSIFFLAGS: Operation not possible due to RF-kill

$ rfkill list 0
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes

I disassembled the system again because I thought I might have made an error
when adjusting the system board and the rfkill switch at the left side. But
that looks ok and I can see that bluetooth is (soft-)switched on correctly =
I flip the switch.

On closer inspection, it looks like the second slot, which I use now,
might have one pin bent slightly as well. I cannot tell for sure whether
there is electrical contact or not.

Just to make sure, I reset the BIOS settings to default values.

My questions: does the Thinkpad care which slot is used for wifi? I know
there are whitelists with PCI IDs. Are these slot-dependent? Do I have
any chance to repair the damage I have done? Are there any recommended
Expresscard wifi cards, preferrably with 802.11n a/b/g? How hard should
I smack myself to be sure I learnt something today?

In this bunker there are women and children. There are no weapons.
[Agree]   [Disagree]

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature

Version: GnuPG v1.4.10 (GNU/Linux)