[ltp] T460s running Debian testing, latest kernels, HW keeps dying

Thomas B. Rücker dm8tbr at bfst.de
Wed Nov 21 15:12:44 CET 2018

Hello everyone!

I'm turning to this list, as I have run out of ideas about the source of
my issues two planar replacements ago.

I have a T460s, it runs Linux, Debian as the distro. Currently that's

I've had issues getting the X-server to drive the Nvidia card in a
useful way that would make it work reliably in my configuration of two
external 4k displays in parallel with the internal display. So I just
stuck to no opengl as it's sufficient for my needs.

The problem is that in the last few months the device has died now 4 or
5 times, each time requiring a planar replacement. Each time it would
become unbootable. The first occurence it had problems turning on and
then just failed to do anything, despite disconnecting batteries, trying
all reset buttons. The following times firmware was still alive. I can
see it go through basic initialization, but handing off in any way to
something else fails, immediately followed by hard reset. I've tried
booting USB sticks, selecting network boot, the diagnostics system,
anything - every time it reboots immediately. I can enter setup, as
that's part of the firmware itself. Tried to reset everything there.
Trying to enter PXE setup by [ctrl][s], hard reboot.

Does anyone have any idea what could be causing this?

It's maddening that I don't understand what is causing this and it just
keeps happening again and again. I keep blaming myself, although I know
that I shouldn't. Every time I devise a hypothesis it fails again. It's
not a floating ground problem, fixed that, happened again. It's not a
thermal problem as far as I can tell, everything in gkrellm seems to be
at most in the upper 50°C. Kept switching around power supplies, doesn't
seem related (Didn't have time to build a probe to test each supply
under load, but at idle they were squeaky clean on an oscilloscope). Two
or three of the planars were refurbs, but the latest one looks to have
been new.

As I use this as my main work device it's always with me and on most of
the time. One of the battery packs has failed due to cycles(?).

I've tried to explain my setup and attempts so far, but feel free to ask
further questions.

Most appreciated would be reports of similar problems /and/ their causes
if they were discovered.



More information about the Linux-Thinkpad mailing list