[ltp] RRe: Fwd: T450s mouse pointer freeze with Arch kernel 5.10.4 and 5.10.4

Michael Topp info at mito-space.com
Sat Jan 9 22:11:52 CET 2021

(3)  Further you could grep your Xorg log for driver input issues like
in the [ Arch wiki ]
<https://wiki.archlinux.org/index.php/Xorg#Input_devices> .

(4)  For potentially missing drivers or X related troubles, you could
also look through the [ Arch wiki ]
<https://wiki.archlinux.org/index.php/Laptop/Lenovo>, the packages or
AUR databases, or if there are any restrictions or helpers for your
model mentioned at [ ThinkWiki ]


Am 09.01.21 um 20:57 schrieb Michael Topp:
> -------- Weitergeleitete Nachricht --------
> Betreff: 	Re: [ltp] T450s mouse pointer freeze with Arch kernel 5.10.4
> and 5.10.4
> Datum: 	Sat, 9 Jan 2021 20:56:00 +0100
> Von: 	Michael Topp <info at mito-space.com>
> An: 	Paul Marwick <paul.marwick at gmail.com>
> Hi Paul,
> I never have experienced such a problem, but two ideas:
> (1)  Does this also happen when starting your desktop from console via
> "startx"? If not, the problem is probably lightdm related.
> (2)  Or, try adding an appropriate hook or a driver module to your [
> mkinitcpio ] <https://wiki.archlinux.org/index.php/Mkinitcpio> and
> regenerate the initramfs; maybe do an additional update-grub. 
> Am 09.01.21 um 04:30 schrieb Paul Marwick:
>> I have Arch Linux Xfce installed on a T450s. Worked very well indeed
>> up until the first of the 5.10.x kernels. After that, I started
>> getting lightdm starting in a very low resolution mode (640x480?). A
>> reboot would usually fix it, until I installed 5.10.4. With that
>> kernel, rebooting didn't help. If I logged in, the resolution would
>> go to normal when Xfce loaded, but the mouse pointer would be locked,
>> not moveable using the touchpad or the trackpoint. Attempting to get
>> to a console to shut down didn't work - all I could get was a
>> blinking cursor. Only way out was to either SSH in from another
>> machine or power cycle the laptop.
>> Following a hint I found, I removed xf86-video-intel, which was a
>> marginal improvement. Still not functional, but at least I could get
>> to a console to do a clean shutdown.
>> A couple of days ago, kernel 5.10.5 arrived. At first, I thought it
>> had solved the problem, since I was able to log in and use the
>> machine normally. Didn't last though - on the next day, I was back to
>> having a locked mouse pointer and nothing usable except consoles.
>> I have tried plugging in a USB mouse, which worked, but isn't a very
>> practical solution - I use the laptop in a number of areas which
>> don't give me anywhere to put a mouse...
>> Has anyone seen this type of problem, or have any ideas as to how to
>> diagnose and (hopefully) fix it? For the moment, I have to roll back
>> to 5.9.14 or use the lts kernel to get the machine to a usable state.
>> Paul.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.linux-thinkpad.org/pipermail/linux-thinkpad/attachments/20210109/2e7c8a81/attachment.html>

More information about the Linux-Thinkpad mailing list