[ltp] Fwd: T450s mouse pointer freeze with Arch kernel 5.10.4 and 5.10.4

Michael Topp info at mito-space.com
Fri Jan 22 22:50:25 CET 2021

-- Strange stuff for sure! I luckily never encountered troubles with the

Any changes booting a fallback kernel?
However, running LTS instead of being bleeding edge is not the worst
idea, in the contrary.

Looks like there's still a new appropriate driver missing.
Or, try dis/enabling other extra options in your xorg conf; or check it
for typos.
Or disable them all (if any) and try running defaults...

How about [ gpm ]
<https://wiki.archlinux.org/index.php/General_purpose_mouse>, does it
work with your trackball? In case you're left to console, it makes
things like c&p easier.

Another idea: If it's an Xorg problem, have a taste of wayland, where I
recommend [ sway ] <https://wiki.archlinux.org/index.php/Sway>, for
instance; started either by tty or a dm. It runs flawlessly in
combination with xwayland, even opengl; when I started using it, my
former (maybe also dbus related) libinput+xorg freezing problems were
totally gone. (Anyway, I still prefer my X desktop which got revived
again after another bunch of updates a year later; yet sway is my spare

Good luck!


Am 22.01.21 um 21:46 schrieb Paul Marwick:
> Hi Michael,
> Sorry for the long delay in replying - been trying to work out what
> was going on. And not getting very far....
> I tried disabling lightdm and starting Xfce manuall. Made no
> difference, the mouse pointer was still locked. I've also tried
> looking through the Xorg log to see if there are any errors, but
> nothing shows up.
> One thing that I have discovered is that the freeze is normally
> temporary. After 2 -3 minutes, both touchpad and trackpoint start
> working. Looking through the journal, I can't find any sign of error,
> other than this:
> systemd-udevd[214]: Worker [220] processing SEQNUM=2968 is taking a
> long time
> systemd-udevd[214]: Worker [220] processing SEQNUM=2968 killed
> systemd-udevd[214]: Worker [220] terminated by signal 9 (KILL)
> systemd-udevd[214]: event6: Worker [220] failedESC
> zeta kernel: psmouse serio1: synaptics: queried max coordinates: x
> [..5676], y [..4758]
> zeta kernel: psmouse serio1: synaptics: queried min coordinates: x
> [1266..], y [1096..]
> zeta kernel: psmouse serio1: synaptics: Trying to set up SMBus access
> zeta kernel: rmi4_smbus 0-002c: registering SMbus-connected sensor
> zeta kernel: rmi4_f01 rmi4-00.fn01: found RMI device, manufacturer:
> Synaptics, product: TM3053-004, fw id: 1741117
> zeta kernel: input: Synaptics TM3053-004 as
> /devices/rmi4-00/input/input21
> zeta kernel: serio: RMI4 PS/2 pass-through port at rmi4-00.fn03
> zeta kernel: psmouse serio3: trackpoint: IBM TrackPoint firmware:
> 0x0e, buttons: 3/3
> Which is around when the trackpoint and trackpad started working. No
> idea what is causing it.
> I am also seeing failures and restarts with lighdm on most boots and
> some coredumps from xorg, though in both cases, they work without any
> visible problems.
> For the moment, I'm running the LTS kernel so I can actually do some
> work on the machine, and trying the new 5.10.x kernels as they come
> through in the hopes of the problem being fixed. I would love to be
> able to work out what is going on, if only so I can raise a bug
> against the relevant software.
> Paul.
> Michael Topp wrote:
>> -------- Weitergeleitete Nachricht --------
>> Betreff:     Re: [ltp] T450s mouse pointer freeze with Arch kernel
>> 5.10.4 and 5.10.4
>> Datum:     Sat, 9 Jan 2021 20:56:00 +0100
>> Von:     Michael Topp <info at mito-space.com>
>> An:     Paul Marwick <paul.marwick at gmail.com>
>> Hi Paul,
>> I never have experienced such a problem, but two ideas:
>> (1)  Does this also happen when starting your desktop from console
>> via "startx"? If not, the problem is probably lightdm related.
>> (2)  Or, try adding an appropriate hook or a driver module to your [
>> mkinitcpio ] <https://wiki.archlinux.org/index.php/Mkinitcpio> and
>> regenerate the initramfs; maybe do an additional update-grub.
>> HTH
>> Am 09.01.21 um 04:30 schrieb Paul Marwick:
>>> I have Arch Linux Xfce installed on a T450s. Worked very well indeed
>>> up until the first of the 5.10.x kernels. After that, I started
>>> getting lightdm starting in a very low resolution mode (640x480?). A
>>> reboot would usually fix it, until I installed 5.10.4. With that
>>> kernel, rebooting didn't help. If I logged in, the resolution would
>>> go to normal when Xfce loaded, but the mouse pointer would be
>>> locked, not moveable using the touchpad or the trackpoint.
>>> Attempting to get to a console to shut down didn't work - all I
>>> could get was a blinking cursor. Only way out was to either SSH in
>>> from another machine or power cycle the laptop.
>>> Following a hint I found, I removed xf86-video-intel, which was a
>>> marginal improvement. Still not functional, but at least I could get
>>> to a console to do a clean shutdown.
>>> A couple of days ago, kernel 5.10.5 arrived. At first, I thought it
>>> had solved the problem, since I was able to log in and use the
>>> machine normally. Didn't last though - on the next day, I was back
>>> to having a locked mouse pointer and nothing usable except consoles.
>>> I have tried plugging in a USB mouse, which worked, but isn't a very
>>> practical solution - I use the laptop in a number of areas which
>>> don't give me anywhere to put a mouse...
>>> Has anyone seen this type of problem, or have any ideas as to how to
>>> diagnose and (hopefully) fix it? For the moment, I have to roll back
>>> to 5.9.14 or use the lts kernel to get the machine to a usable state.
>>> Paul.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.linux-thinkpad.org/pipermail/linux-thinkpad/attachments/20210122/88b40b12/attachment.html>

More information about the Linux-Thinkpad mailing list