[ltp] Linux-2.2.16 and VMware

Friedemann Baitinger linux-thinkpad@www.bm-soft.com
Mon, 9 Oct 2000 20:45:26 +0200 (CEST)

Hash: SHA1

On Wed, 19 Jul 2000, Friedemann Baitinger wrote:

> since VMware was mentioned lately quite a few times I think it's
> probably worthwhile to mention the experiences I made with it in
> conjunction with linux-2.2.16:
> After I had upraded 3 of my Linux servers with 2.2.16 shortly after that
> kernel came out I finally decided to upgrade the ThinkPad (RH
> 6.2) too. It worked all fine until I started VMware running NT 4.0 as a
> guest. As soon as the NT tried to connect through host-only networking
> to some other host the machine died so badly that NT's disk was totaly
> corrupted. The hang was consistently reproducable but only when
> connected to a TokenRing network. In my Ehthernet LAN it worked fine. In
> the course of investigating I have also upgraded to the latest version
> of the VMware distribution, Version 2.0.1 but it wasn't any better with
> this version. Since the NT's disk file consistently crashed so badly
> that I had to restore a backup (fortunately I had one) I finally went
> back to 2.2.14 on the ThinkPad and everything works just fine as it did
> before.
> Is anybody successfully using a ThinkPad 770X with Linux-2.2.16 and
> VMware 2.0.1 with NT 4.0 as a guest OS and doing host-only networking
> through a Token Ring network? If you plan to do so, and in fact whenever
> you make significant changes to the setup, I'd like to strongly suggest
> to make a backup of VMware's guest OS disk file.

Just to give you an update on how things are going here: Over the
weekend I have upgraded to linux-2.2.17, pcmcia-cs-3.1.21, and VMware
2.0.2 Build 621. At first the problem seemed to be gone. I was able to
do host only networking through Token Ring, however, after about half an
hour the system hung completely such that I needed Power-Off/On to
recover. The only good thing is that this time the hang did not crash
the VMware NT image. I'm now back at linux-2.2.14 which still works just
as expected.

Does anybody have any ideas where to look for the problem? Is it the
linux kernel? Is it the pcmcia package? Is it VMware?

- -- 
Friedemann Baitinger      fb@baiti.net       http://baiti.net/fb/
Version: GnuPG v1.0.1 (GNU/Linux)
Comment: For info see http://www.gnupg.org


----- The Linux ThinkPad mailing list -----
The linux-thinkpad mailing list home page is at: