[ltp] A20p hibernate/resume X freeze [solved?]

Tod Harter linux-thinkpad@www.bm-soft.com
Mon, 17 Sep 2001 14:09:16 -0400

Well, my experience with Linux Intel card drivers has never been good in 
general. Personally I think they're just plain bad drivers from the start. I 
had 3 different ISA intel eepro cards of various ilks in my home machine and 
if they worked at all they always caused crashes (but win98 had no problem 
with them).

Maybe more relevantly I find that if I disconnect from the network on my A20p 
and take it home, then it goes into suspend that the eepro driver becomes 
porked. ifconfig then reports "SIOCCTL NO SUCH DEVICE" and its necessary to 
reboot to get it back. 

I wish IBM would pick a different vendor for their ethernet interface...

On Monday 17 September 2001 07:49, you wrote:
> I think I've solved it: I altered the apm scripts to rmmod the eepro100
> module before hibernating and insert it after resuming [it used to just
> ifconfig the interface down and up], and the laptop just came back, with
> GDM in control of the display, after hibernating overnight. Hopefully this
> wasn't an ill-timed fluke, and the problem is now solved.
> I'm not sure why X triggered the freeze, though - does gdm do network-y
> things by default? - No, that can't be it, [I think] it froze once when
> I'd hibernated w/o logging out first... Oh well... weirdness abounds...

----- The Linux ThinkPad mailing list -----
The linux-thinkpad mailing list home page is at: