[ltp] Getting USB to work on IBM Thinkpad i1300

Madhusudan Singh linux-thinkpad@www.bm-soft.com
Fri, 21 Sep 2001 04:01:16 -0400 (EDT)

I am running RH Linux 7.1 (kernel 2.4.2-2) on an IBM Thinkpad i1300.
When I did the install from the bootable CD, the system froze at
/sbin/loader unless I passed "linux nousb" as an option.

The first time I booted up, I found that it froze when :

1. It tried to load usb-ohci.
2. Tried to run kudzu.

(Very possibly, these two "hangs" were related to each other, just a

I disabled kudzu with a simple /sbin/chkconfig kudzu --del, however I
still need to pass linux nousb at LILO prompt if I do not want a frozen
machine on my hands.

Now this is :
1. Annoying.
2. Wasting the USB capabilities of the 2.4x kernel (I have a desktop
machine that runs usb-uhci perfectly).

After an abortive install of ltmodem (my windmodem is a Lucent SoftModem
AMR <--- bummer), lspci -vv yields a parse error in /usr/share/pci.ids at
line 1934.

However cat /proc/pci yields (for the USB controller) :

Bus 0, device 20, function 0:
	USB Controller: Acer Laboratories Inc. [ALi] M5237 USB (rev 3)
	IRQ 10.
	Master Capable. Latency=32. Max Lat=80
	Non-prefetchable 32 bit memory at at 0x82400000 [0x82400fff]

(Typing all those hex addresses isn't fun :( )

Now, the question is :

	How do I get USB working on this laptop ?


----- The Linux ThinkPad mailing list -----
The linux-thinkpad mailing list home page is at: