[ltp] various RH 7.3 problems

David Margrave linux-thinkpad@www.bm-soft.com
Sat, 22 Jun 2002 23:18:26 -0700

Hash: SHA1

I have tried EVERYTHING to get a pcmcia modem working with redhat 7.3 on
my tp600.  I have tried:

1) excluding any combination of interrupts you care to think of from
2) rebuilding the kernel without pcmcia modules, bulding pcmcia_cs
3) Changing /etc/sysconfig/pcmcia to use i8xxx (whatever it is) istead
of yenta_socket.
4) Tried feeding the i8xxx module the 'irq_list' option

Nothing helps.  The behavior ranges from 'freeze until card is removed'
at best, to ' spew kernel trace to console', to 'freeze hard' at worst.
~ Ocassionally there is some muttering in the logs like 'unable to
reserve io xxx irq xxx for serial_cs'.

I thought, 'I read something about that "yenta" think only liking
cardbus cards and not really supporting older cards at this stage,' and
tried the modem in a dell laptop also with rh 7.3 and it works fine.

I would advise any thinkpad 600 user to stay away from redhat 7.3 and
2.4 kernels at this stage, that is, if you have a pcmcia modem you want
to use.


Chris Dailey wrote:

|Except for having to add the sound module for the CS4232 I didn't have any
|problems loading RedHat 7.3 onto the TP 600E. As usual there are a some
|quirks with RedHat KDE. Currently having problems setting up Tripwire, KDE
|mail seems to have a problem if I set the GPG passwd to stay resident.
|Haven't run across any others though. Oh yeah, I forgot. I can't use the
|dialup if I have my ethernet card installed. Not really a big deal but it
|drove me nuts for a couple of days figuring it out.
|Chris Dailey
|On Sat, 15 Jun 2002, Steve Tell wrote:
|>Date: Sat, 15 Jun 2002 19:47:45 -0400 (EDT)
|>From: Steve Tell <tell@telltronics.org>
|>Reply-To: linux-thinkpad@www.bm-soft.com
|>To: linux-thinkpad@www.bm-soft.com
|>Subject: Re: [ltp] various RH 7.3 problems
|>Um, which thinkpad model gave you these troubles?
|>Anyone tried RH 7.3 on a TP 600E?
|>I found RH7.2 to be smooth as glass on a 600E (2645-UN1) but would like
|>the newer gnome and KDE apps of 7.3.
|>Any issues with the new kernel or anything else?
|>On Sat, 15 Jun 2002, David Margrave wrote:
|>>As with all their releases, redhat didn't quite get it right with redhat
|>>7.3 as far as laptops go.  It took considerably less hacking than
|>>previous releases to get everything going, but there are still problems.
|>>1) sometimes it freezes at boot time while 'mounting other filesystems'
|>>if there is a pcmcia modem in the slot at boot time.  I've removed the
|>>/etc/rc.d/rc3.d scripts that appear to have anything to do with remote
|>>mounting (nfs, autofs, etc).  But it still does it, so I'll keep
|>>deleting init scripts until I find it.
|>>2) booting without a modem in the slot and then inserting it after
|>>booting will also make it freeze up (sometimes you can recover by
|>>removing the modem, sometimes you have to take out the battery!).  It
|>>complains about "usb-uhci-c: interrupt... host controller halted, trying
|>>to restart".  Could it be that I'm failing to exclude an interrupt from
|>>the pcmcia.opts file?  If redhat worried about minor stuff like this in
|>>their installer instead of making pictures of Alan Cox in a krispy kreme
|>>3) sometimes it fails to bring up the lo interface, saying 'someone else
|>>is already using' or some such nonsense.
|>Steve Tell  tell@telltronics.org
|>----- The Linux ThinkPad mailing list -----
|>The linux-thinkpad mailing list home page is at:
|----- The Linux ThinkPad mailing list -----
|The linux-thinkpad mailing list home page is at:

Version: GnuPG v1.0.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


----- The Linux ThinkPad mailing list -----
The linux-thinkpad mailing list home page is at: