[ltp] USB

Joel Ebel linux-thinkpad@linux-thinkpad.org
Mon, 03 Nov 2003 21:34:46 -0500

Sounds like my problems could be different than yours, since I do 
experience the problems in windows XP as well.  I have not tried a 
different USB 2 hub yet, so perhaps I'll try that and see if it has 
similar problems.


Paul Kaplan wrote:
> Thanks for your commiseration.  I don't think it's a defective port replicator 
> for two reasons(, but I will try re-seating).  First, it works fine under 
> W2KSP4.  Second, I have a(n second) external USB2 hub.  It too works 
> correctly under W2K no matter whether its plugged in to the box or the 
> replicator.  However under Linux it is just as flaky as the ports on the 
> replicator.  I wonder whether the problem is in the 2.4 kernel implementation 
> of USB, since it doesn't support hot swapping the way it does under W.  I 
> gather that 2.6 is supposed to address some of these issues.
> P
> On Monday 03 November 2003 07:26 am, Joel Ebel wrote:
>>I have had similar experiences with my T40.  My mouse would jump around
>>and click at random times, and my Sony Clie would only sync when it felt
>>like it.  Sometimes devices wouldn't register at all.  All when plugged
>>into the port replicator.  Everything works fine when plugged directly
>>into the T40.  I was usually able to fix the not connecting at all by
>>reseating the T40 in the port replicator, but I could never fix the
>>flakiness.  I just use the ports on the T40 directly now.  Maybe IBM
>>would replace the port replicator if you tried though.  If they do, let
>>me know.  I might try myself.
>>Paul Kaplan wrote:
>>>Has anyone gotten the USB ports on a port replicator or an external USB2
>>>hub to work correctly?  My USB devices work correctly when plugged
>>>directly into the ports on a T40 itself, but are flaky or totaly
>>>non-functional when plugged into the port replicator or the hub.
>>>I'm using a Mandrake stock 2.4.22 kernel w/ 1Gb memory.