[ltp] Cisco Wireless card (and hibernation issues...)

Heiko Rosemann linux-thinkpad@linux-thinkpad.org
Tue, 4 Nov 2003 23:38:01 +0100 (CET)

On Tue, 4 Nov 2003, Johnny Casey wrote:

> Carl Nygard wrote:
> [Fabrice's airo_mpi driver for Cisco Wireless card]
> > For anyone cluefully interested, hibernation seems to hang on wakeup (X
> > screen is hashed and keyboard non-functional) only after extended
> > periods of time in hibernation (AC or battery, doesn't matter).

Funky. I sometimes get X crashes (I guess it has to do with my lately
patched kernel - tried swsusp and I'm too lazy to make it work and therefore
will stick with BIOS hibernation) when the system only does a STR, no STD,
and later switches over to STD... I have to dig into this when I'll find the
time, since I don't even know why all the keys now (since that kernel patch,
IIRC) generate STR-events, they generated STD-events before...

And I got hangs as you describe them when I had the airo_mpi driver loaded
and connected to an access point when I tried to suspend. The screen just
turned black, external monitor could still be switched on/off/both and
volume keys continue working - but I can only hard-reset the system. No
magic keys, nothing.

> If IRC one of the recent Kernel Traffic issues stated that hiberation
> might not work due to the system clock not being correct.
> Maybe you could add a call to "hwclock --hctosys" in the appropriate script?

Could there be any connection to a hang in the shutdown after
hibernation-wakeup-cycles? It hangs sometimes (not predictable) after saying
"Saving system time to hardware clock" (which is immediatly followed by a
call to hwclock --systohc) - so it could be there.

Any ideas?