[ltp] My Wireless Experiences with a T41

linux-thinkpad@linux-thinkpad.org linux-thinkpad@linux-thinkpad.org
Thu, 13 Nov 2003 19:51:17 +0000 (GMT)

On Thu, 13 Nov 2003, Sean Dague wrote:

> For what it is worth, I happily run bellet's airo_mpi driver on a T40,
> firmware 5.00.03, Linux Mandrake 2.4.22-21mdk kernel.  The older versions of
> the driver (i.e. August & Sept releases) used to give up the ghost after
> some period of time, or under heavy traffic, but everything has been great
> after the October releases.
> On certain waps I needed to use the acu utility to bring up the connection,
> but at home, at 128bit WEP, I can just use the linux wireless tools directly.
> 	-Sean

Sean, can I ask if this is in Ad-Hoc mode or Managed?  I've tried
endlessly to get my Aironet 350 miniPCI working with the Fedora
2.4.22 kernel and given up: in Ad-Hoc mode (WEP on).  Works fine in
managed.  I think Fabrice alluded to the fact that he knows Ad-Hoc is
broken just now: although it worked fine on my custom 2.4.21 kernel
in Red Hat 9.

I hope I'm not misunderstanding the problem, because it's driving me
mad.  I've tried the (nasty) Cisco driver instead, and can't get
either to work: acu sometimes crashes, bcard sometimes hangs the OS,
the addition of a WEP key via the acu utility again doesn't work.
All this worked ok with 2.4.21-ac1/RH9.

Has anyone actually got the Cisco 350 miniPCI working with the stock
fedora kernel in Ad-Hoc mode?  I don't think I have a choice as I
don't have an access point, just a linux firewall/router with another
802.11b card in: I assume I can't run Managed in this environment(?).