[ltp] How to turn on DMA on R40, MDK9.1

Ivarsson, Torbjorn (T) linux-thinkpad@linux-thinkpad.org
Sat, 22 Nov 2003 10:06:58 -0600

I'm trying to get Mandrake 9.1 to run smoothly on my R40 (2722). The default kernel from the CDs is 2.4.21-0.13mdk. AFAIK, this is running without any problems - except that DMA is not available... I really want DMA enabled.

When I try to do:
	hdparm -d1 /dev/hda
I get the error message:
	HDIO_SET_DMA failed: Operation not permitted

I've tried to recompile the kernel (0.13mdk as well as 0.25mdk), but I can't really find any options where I can "turn on" DMA in the kernel. Does anyone know the name of the option I need to enable?

I also tried to kompile Mandrake's 2.4.22-0.21mdk kernel, and without any adjustments DMA works fine; however, the computer crashes when trying to get back from suspend (haven't been able to fix it)... Frustrating.

Any help is appreciated. As long as I can do my coding with QT I don't really care what distro to use. So if anyone recommends a "better" (i.e. for them fully working) distro, I'm willing to try it.