[ltp] How to turn on DMA on R40, MDK9.1

Neil Weisenfeld linux-thinkpad@linux-thinkpad.org
Sat, 22 Nov 2003 13:16:02 -0500

I think that you found your answer re: DMA, which is that you need to
run a more recent kernel.  I don't know anything about Mandrake, but at
least the chipset in the T40 wasn't supported in, for instance, the
kernel that shipped originally with RedHat 9.  

What comes with Fedora seems to work well including suspend/resume.

If you're comfortable playing with these things, I can send you the
patches I wrote for an earlier kernel 2.4.19 or 21, not sure which, and
you can try to apply them to Mandrake's kernel or maybe check out Fedora
or a more recent kernel.org 2.4 series kernel.


On Sat, 2003-11-22 at 11:06, Ivarsson, Torbjorn (T) wrote:
> I'm trying to get Mandrake 9.1 to run smoothly on my R40 (2722). The default kernel from the CDs is 2.4.21-0.13mdk. AFAIK, this is running without any problems - except that DMA is not available... I really want DMA enabled.
> When I try to do:
> 	hdparm -d1 /dev/hda
> I get the error message:
> 	HDIO_SET_DMA failed: Operation not permitted
> I've tried to recompile the kernel (0.13mdk as well as 0.25mdk), but I can't really find any options where I can "turn on" DMA in the kernel. Does anyone know the name of the option I need to enable?
> I also tried to kompile Mandrake's 2.4.22-0.21mdk kernel, and without any adjustments DMA works fine; however, the computer crashes when trying to get back from suspend (haven't been able to fix it)... Frustrating.
> Any help is appreciated. As long as I can do my coding with QT I don't really care what distro to use. So if anyone recommends a "better" (i.e. for them fully working) distro, I'm willing to try it.
> Thanks,
> T.