[ltp] How to turn on DMA on R40, MDK9.1

Richard Neill linux-thinkpad@linux-thinkpad.org
Sat, 22 Nov 2003 18:20:01 +0000

If the newer kernel works, it sounds like DMA for that motherboard is 
probably not supported in the old kernel.
You might find that other bugs have been fixed too in Mdk 9.2. Mandrake 
9.2 ISOs are now available for public download (the isos were originally 
only for Mandrakeclub members, and released by bittorrent, but you can 
get them by FTP now).

If you're getting suspend crashes (apm -s), you might find that this 
solution helps - I use it with Mdk 9.1 on my a22p:

Best wishes


Ivarsson, Torbjorn (T) wrote:
> I'm trying to get Mandrake 9.1 to run smoothly on my R40 (2722). The default kernel from the CDs is 2.4.21-0.13mdk. AFAIK, this is running without any problems - except that DMA is not available... I really want DMA enabled.
> When I try to do:
> 	hdparm -d1 /dev/hda
> I get the error message:
> 	HDIO_SET_DMA failed: Operation not permitted
> I've tried to recompile the kernel (0.13mdk as well as 0.25mdk), but I can't really find any options where I can "turn on" DMA in the kernel. Does anyone know the name of the option I need to enable?
> I also tried to kompile Mandrake's 2.4.22-0.21mdk kernel, and without any adjustments DMA works fine; however, the computer crashes when trying to get back from suspend (haven't been able to fix it)... Frustrating.
> Any help is appreciated. As long as I can do my coding with QT I don't really care what distro to use. So if anyone recommends a "better" (i.e. for them fully working) distro, I'm willing to try it.
> Thanks,
> T.

rn214@hermes.cam.ac.uk  **  http://www.richardneill.org
Richard Neill, Trinity College, Cambridge, CB21TQ, U.K.