[ltp] IR on T23?

Tino Keitel linux-thinkpad@linux-thinkpad.org
Mon, 8 Sep 2003 09:13:35 +0200

On Sun, Sep 07, 2003 at 04:27:16 -0400, bjorn@docs.uu.se wrote:
> Has anyone had any luck whatsoever getting the infrared to work on a
> T23?
> Supposedly, the IR-chipset is the nsc-ircc, but when I try to insmod
> the driver, I get the following message:
> nsc-ircc, Found chip at base=0x02e
> nsc-ircc, Wrong chip version ff
> I commented out the section that tests the chip version in the
> sources, as suggested in various places, and the driver seems to load.
> I've tried following the IrDA-howto to set things up and try to detect
> the presence of my iPAQ, but I've had no luck even detecting it so
> far.
> I then proceeded to set the IR up to be "enabled" instead of "OS
> controlled". The BIOS setup says ioport=0x2f8, irq=3, dma=3. I've
> set it up with:
> options nsc-ircc dongle_id=0x09 io=0x2f8 irq=3 dma=3
> but now when I load it, I get:
> nsc-ircc, Found chip at base=0x02e
> nsc-ircc, driver loaded (Dag Brattli)
> nsc_ircc_open(), can't get iobase of 0x2f8
> My guess is either I've screwed that part up, or my IrDA chip really
> isn't supported correctly by the driver. Anyone have any ideas?

I had similar problems when I tried to use the nsc-ircc driver. I also
worked at the source level, but at the end I found out that I forgot to
call "setserial /dev/ttyS1 uart none port 0 irq 0". If you don't do
this, the resources of the IR port will be allocated by the serial

Once I did this, the driver loads perfectly. It worked on a A30 and on
a T20 with a 2.4.21 kernel, throughput was ~360 kbyte/s using IrLAN.