[ltp] Weird wifi slowness

Steven J. Owens linux-thinkpad@linux-thinkpad.org
Wed, 6 Jun 2012 08:14:56 +0000

Hi all,

     I have a thinkpad t520 with nvidia, intel i7-2720QM and Intel
Centrino Wireless-N 1000.  For months I have been, perhaps
incorrectly, cursing comcast for bad network performance.

     It's a specifically weird kind of poor performance.  My ssh
sessions have nice low latency and stay connected, but web pages,
rsync and scp get slower and slower, and youtube or even audio
services like pandora are mostly useless.

     I mostly assumed comcast was the culprit, but the problems
started a few months ago when I rearranged my network hardware, so I
thought it was possible that was the problem.  So, I recently
rearranged the network hardware in my house to bring my access point
within a few feet of my laptop.

     Still the same problem, but when I used a cat5 cable to plug the
laptop directly into the router... the problems went away, completely!

     It's possible this could just be fortuitous timing, maybe comcast
finally fixed something, but I've had odd problems with wifi on linux
before (with my thinkpad t43p I encountered a problem where the
IPW2200 module would constantly disconnect/reconnect).

     Also, I don't know much about Centrino wireless-N 1000, so it 
may be there's some obvious configuration issue I'm missing.

Steven J. Owens
puff@darksleep.com / (412) 401-8060 cell 
| "I'm going to make broad, sweeping generalizations and strong,
|  declarative statements, because otherwise I'll be here all night and
|  this document will be four times longer and much less fun to read.
|  Take it all with a grain of salt." 
|  - http://darksleep.com/notablog